Bug 810030 - SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /usr/bin/mount.
SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /usr/...
Status: CLOSED DUPLICATE of bug 809832
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6971fa9983ece59d5d4d214bff7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 19:22 EDT by Michal Ambroz
Modified: 2012-04-04 19:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-04 19:51:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Ambroz 2012-04-04 19:22:08 EDT
libreport version: 2.0.10
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc17.x86_64
time:           Thu 05 Apr 2012 01:21:41 AM CEST

description:
:SELinux is preventing /usr/bin/bash from 'getattr' accesses on the file /usr/bin/mount.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that bash should be allowed getattr access on the mount file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep script.sh /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:tuned_t:s0
:Target Context                system_u:object_r:mount_exec_t:s0
:Target Objects                /usr/bin/mount [ file ]
:Source                        script.sh
:Source Path                   /usr/bin/bash
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           bash-4.2.24-1.fc17.x86_64
:Target RPM Packages           util-linux-2.21.1-1.fc17.x86_64
:Policy RPM                    selinux-policy-3.10.0-110.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc17.x86_64 #1 SMP
:                              Thu Mar 29 18:18:26 UTC 2012 x86_64 x86_64
:Alert Count                   4
:First Seen                    Thu 05 Apr 2012 01:19:14 AM CEST
:Last Seen                     Thu 05 Apr 2012 01:19:14 AM CEST
:Local ID                      591497c0-f2e4-4a21-9513-c40322f4e153
:
:Raw Audit Messages
:type=AVC msg=audit(1333581554.169:1462): avc:  denied  { getattr } for  pid=14200 comm="script.sh" path="/usr/bin/mount" dev="dm-0" ino=190482 scontext=system_u:system_r:tuned_t:s0 tcontext=system_u:object_r:mount_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1333581554.169:1462): arch=x86_64 syscall=stat success=no exit=EACCES a0=14a12c0 a1=7fff9bfdf9e0 a2=7fff9bfdf9e0 a3=f items=0 ppid=10725 pid=14200 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=script.sh exe=/usr/bin/bash subj=system_u:system_r:tuned_t:s0 key=(null)
:
:Hash: script.sh,tuned_t,mount_exec_t,file,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Michal Ambroz 2012-04-04 19:51:45 EDT
Should be probably solved together with other events triggered by 
"tuned-adm profile something".

Marking as duplicate of 809832.

*** This bug has been marked as a duplicate of bug 809832 ***

Note You need to log in before you can comment on or make changes to this bug.