Bug 810039 - ntfsresize cannot run in F17 Beta RC3 anaconda because of missing library
ntfsresize cannot run in F17 Beta RC3 anaconda because of missing library
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
17
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
Depends On:
Blocks: F17-accepted/F17FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-04-04 19:56 EDT by Adam Williamson
Modified: 2012-04-18 22:13 EDT (History)
8 users (show)

See Also:
Fixed In Version: lorax-17.14-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 19:06:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-04-04 19:56:05 EDT
17 Beta RC3 - If I try and select 'Shrink existing filesystem' on a system which has a disk with two NTFS partitions, anaconda says there's no resizable filesystems present. Investigating, I see in the logs:

ERR program: Running... ntfsresize -m /dev/sda2
ERR program: ntfsresize: error while loading shared libraries: libntfs-3g.so.83: cannot open shared object file: No such file or directory

ntfsresize comes from ntfsprogs; libntfs-3g.so.83 comes from ntfs-3g. They're both from the same .src.rpm. There is no /lib64/libntfs* - so it's not a version mismatch, the library is just completely missing. Being stripped by lorax?
Comment 1 Adam Williamson 2012-04-04 20:03:12 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Brian Lane 2012-04-04 20:04:02 EDT
This seems to be removing more than it should:
removefrom ntfs-3g --allbut /usr/sbin/mount.ntfs* /${libdir}/*

ntfs-3g has these libraries:
/lib64/libntfs-3g.so.81
/lib64/libntfs-3g.so.81.0.0
Comment 3 Brian Lane 2012-04-05 10:38:07 EDT
The libraries moved to /usr/lib64
Comment 4 Adam Williamson 2012-04-06 01:19:01 EDT
Nominating as NTH for Beta. It's obviously not susceptible to fixing with an update, and it's a pretty safe change if all it involves is *not* deleting files in lorax.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2012-04-09 23:16:12 EDT
This is accepted as NTH for the reason cited in comment #4.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2012-04-11 01:06:24 EDT
still valid in RC4. there's no lorax 17.14 build yet.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Fedora Update System 2012-04-11 10:20:47 EDT
lorax-17.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lorax-17.14-1.fc17
Comment 8 Fedora Update System 2012-04-11 21:08:46 EDT
Package lorax-17.14-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-17.14-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5697/lorax-17.14-1.fc17
then log in and leave karma (feedback).
Comment 9 Kamil Páral 2012-04-12 08:12:12 EDT
Beta is out, moving to F17 Final NTH
Comment 10 Fedora Update System 2012-04-18 19:06:29 EDT
lorax-17.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.