Bug 810067 - ant classpath problems with rpm_mode=true
ant classpath problems with rpm_mode=true
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ant (Show other bugs)
6.0
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Java maintainers
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-04 23:50 EDT by Shawn Heisey
Modified: 2016-07-23 19:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-22 02:15:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shawn Heisey 2012-04-04 23:50:43 EDT
Description of problem:
When rpm_mode=true, Ant has problems locating and using a jarfile that exists in ~/.ant/lib

Steps to Reproduce:
1. Install subversion, ant, ant-junit, ant-nodeps, and an Oracle JDK.
2. > svn co http://svn.apache.org/repos/asf/lucene/dev/trunk
3. > cd trunk
4. > ant ivy-bootstrap
5. Observe that a jar for ivy has been downloaded to ~/.ant/lib.
6. > ant
7. Observe that it fails to find ivy.
8a. Comment out rpm_mode=true in ant.conf.
8b. OR: Add rpm_mode=false to ~/.ant/ant.conf
9. > ant
10. Observe that ivy is found and that ant proceeds to run Lucene tests.
11. Download Ant from apache's website.
12. Configure ANT_HOME.
13. > /path/to/downloaded/ant
14. Observe that once again ivy is found and works.

Additional info:

I'm not 100% sure that I've listed all the package requirements 
The ivy jar is shown when echoing java.class.path and rpm_mode=true, so I don't know why it isn't found.

CentOS release 6.0 (Final)
Repos used: base, updates, extras, centosplus, contrib, cr, epel, rpmforge.
Also happens on a CentOS 6.2 system.
Lucene bug: https://issues.apache.org/jira/browse/LUCENE-3946
Comment 1 Shawn Heisey 2012-04-05 00:11:42 EDT
Others have reported having the same problem with some releases of Fedora.  I have not tried this on 5.x.
Comment 3 RHEL Product and Program Management 2012-09-07 01:35:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 4 Mikolaj Izdebski 2016-07-22 01:39:41 EDT
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.
Comment 5 RHEL Product and Program Management 2016-07-22 02:15:50 EDT
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 6 Shawn Heisey 2016-07-23 19:35:01 EDT
I'm reasonably certain that this probably still affects version 7.  On the Lucene/Solr mailing lists, we have to frequently tell people that they cannot use the redhat-packaged version of ant to build our software.  They must download ant themselves and set ANT_HOME.

Note You need to log in before you can comment on or make changes to this bug.