Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 810077 - systemd-sysvinit is obsoleted by systemd-44-4.fc18.i686
systemd-sysvinit is obsoleted by systemd-44-4.fc18.i686
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 01:01 EDT by Ivo Sarak
Modified: 2014-01-21 18:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 05:28:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2012-04-05 01:01:18 EDT
Description of problem:
yum update will result of complain about "systemd-sysvinit is obsoleted by systemd-44-4.fc18.i686".

Version-Release number of selected component (if applicable):

yum-3.4.3-23.fc18.noarch

How reproducible:

Always.

Steps to Reproduce:
1. Try to run yum update.
  
Actual results:

"Running Transaction Check
ERROR with transaction check vs depsolve:
systemd-sysvinit is obsoleted by systemd-44-4.fc18.i686
Please report this error in https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&component=yum"


Expected results:

Update as usual.

Additional info:

For some strange reason I am unable to find systemd-sysvinit on my system:
[root@ragana ~]# rpm -qa|grep systemd
wine-systemd-1.5.0-2.fc18.noarch
systemd-44-3.fc18.x86_64
systemd-sysv-44-3.fc18.x86_64
systemd-analyze-44-3.fc18.x86_64
systemd-44-3.fc18.i686
[root@ragana ~]#
Comment 1 Panu Matilainen 2012-04-05 03:13:53 EDT
Please attach the full output of the 'yum update' that leads to this, preferably with -d5 to get more information. This looks like it could be a bug in rpm, but I'm not able to reproduce it easily, it might need some specific combination of packages to trigger.
Comment 2 Panu Matilainen 2012-04-05 04:54:52 EDT
Ahhah, never mind the above request, the necessary clue was there afterall: there are systemd.x86_64 and systemd.i686 present.

It's indeed a bug in rpm, will fix shortly.
Comment 3 Panu Matilainen 2012-04-05 05:28:43 EDT
Fixed in rawhide now. Here's the koji build if you want to try it before it hits the public rawhide mirrors:
http://koji.fedoraproject.org/koji/buildinfo?buildID=311789

Note You need to log in before you can comment on or make changes to this bug.