Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 810082 - [RFE] support hard mounts for NFS in addition to soft mounts
Summary: [RFE] support hard mounts for NFS in addition to soft mounts
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.3.4
Assignee: Itamar Heim
QA Contact: Aharon Canan
URL:
Whiteboard: storage
: 574733 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-05 05:53 UTC by Ayal Baron
Modified: 2014-12-30 10:17 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-04 09:25:19 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Ayal Baron 2012-04-05 05:53:30 UTC
Description of problem:
Currently NFS storage domains are mounted with soft mount.  Although there is no technical issue with it, hard mounts are much more common hence tested better so it's preferable to support hard mounts.
To prevent vdsm from hanging support should be for hard,intr and have mechanisms to interrupt I/O in the control path after a timeout

Comment 1 Ayal Baron 2012-04-05 05:54:32 UTC
*** Bug 574733 has been marked as a duplicate of this bug. ***

Comment 2 Itamar Heim 2013-12-07 19:40:54 UTC
is this still relevant with all the time we are with soft mounts?

Comment 3 Ayal Baron 2013-12-08 10:47:02 UTC
(In reply to Itamar Heim from comment #2)
> is this still relevant with all the time we are with soft mounts?

It will always be relevant regardless of the current way being 100% ok.
1. With NFS people prefer their VM not pausing on EIO but hanging the I/O.
2. Perception wise people prefer hard mounts

On the flip side, changing everything to work with hard mounts might be challenging due to the need to detect hangs and interrupt processes such as dd (in the control path)

Comment 6 Itamar Heim 2014-08-04 09:25:19 UTC
don't remember anyone asking about this for a while. its making things complex for the spm/sdm data operations. we work correctly and robustly with soft mounts


Note You need to log in before you can comment on or make changes to this bug.