Bug 81010 - no dependency on /boot/boot.b (owned by package lilo)
no dependency on /boot/boot.b (owned by package lilo)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-03 08:48 EST by Dries Verachtert
Modified: 2007-04-18 12:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-06 01:03:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dries Verachtert 2003-01-03 08:48:36 EST
Description of problem: 
The kernel package doesn't have dependencies on lilo. 
If you install the kernel package (kernel-2.4.18-19.8.0.i686.rpm) without lilo, rpm gives the 
following error (probably from the scripts):  
grubby: unable to open /boot/boot.b: No such file or directory 
grubby fatal error: unable to find a suitable template 
 
The file /boot/boot.b belongs to the package lilo so kernel should depend on lilo i guess. 
 
Version-Release number of selected component (if applicable): 
tested with kernel-2.4.18-19.8.0.i686.rpm, lilo-21.4.4-20.i386.rpm (redhat 8.0 with updates) 
 
How reproducible: 
every time 
I can provide you with a script if you wish. 
 
Steps to Reproduce: 
1. start the installation of a new rootfilesystem in a directory (for example for creating a 
bootable cd): ROOT =/tmp/root , mkdir -p $ROOT/var/lib/rpm ; rpm --initdb --root=${ROOT} 
2. install all rpms needed to satisfy the dependencies of kernel 
3. install the kernel rpm 
     
Actual results: 
error from the post-install script (i think) of the kernel rpm 
 
Expected results: 
no errors :-) 
a dependency on lilo 
 
Additional info:
Comment 1 Jeremy Katz 2003-01-06 01:03:38 EST
This is because you have a lilo.conf in your chroot which makes it appear as
though lilo is the boot loade rbeing used even though you don't have lilo
installed.  Which makes the error perfectly reasonable because grubby does try
to make sure you continue to have a working boot loader after upgrading kernels.
Comment 2 Andrew Burgess 2004-10-24 23:43:18 EDT
I'm using FC2, removed lilo long ago and still have a lilo.conf file 
(and I get this error). Since I assume 'rpm -e lilo' did not remove 
(or rename) the file perhaps grubby should check something else to 
prove that lilo is being used? I renamed lilo.conf and now the error 
is gone. Thanks!

Note You need to log in before you can comment on or make changes to this bug.