This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 810107 - Kdump can't use a renamed NIC for remote dump.
Kdump can't use a renamed NIC for remote dump.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Baoquan He
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 810111
  Show dependency treegraph
 
Reported: 2012-04-05 03:46 EDT by WANG Chao
Modified: 2013-05-27 02:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 810111 (view as bug list)
Environment:
Last Closed: 2013-05-27 02:12:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description WANG Chao 2012-04-05 03:46:45 EDT
Description of problem:

In first kernel, udev rule may rename an NIC from eth0 to em1. In this case when building kdump image, 99kdumpbase/module-setup.sh will record em1 in /etc/cmdline.d/40ip.conf in the kdump initramfs.

But on second kernel, we don't have that renaming udev rule, so the original NIC will appear to be eth0 ( not renamed to be em1). Because we have configured kdump to use em1 when building kdump image, and we don't have em1 on second kernel, dump to a remote target will fail.

Version-Release number of selected component (if applicable):
kexec-tools-2.0.3-42.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
On first kernel booting:
[   25.221669] igb 0000:01:00.0: eth0: (PCIe:2.5Gb/s:Width x4) 00:15:17:a2:71:b4 
[   25.229718] igb 0000:01:00.0: eth0: PBA No: 1040FF-0FF 
[   25.235470] igb 0000:01:00.0: Using MSI-X interrupts. 4 rx queue(s), 4 tx queue(s) 
[   25.244172] igb 0000:01:00.1: PCI INT A -> GSI 28 (level, low) -> IRQ 28
[..]
[   25.680989] udevd[668]: renamed network interface eth0 to em1

On second kernel, udevd won't rename the NIC name.
Comment 1 Fedora Admin XMLRPC Client 2012-04-16 02:12:58 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 2 Fedora Admin XMLRPC Client 2013-02-25 03:06:20 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Note You need to log in before you can comment on or make changes to this bug.