Bug 810108 - SM unable to auto-subscribe, server does not support service levels
SM unable to auto-subscribe, server does not support service levels
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Strachota
SAM QE List
: Triaged
Depends On:
Blocks: sam11-tracker
  Show dependency treegraph
 
Reported: 2012-04-05 03:48 EDT by Jakub Dorňák
Modified: 2012-08-22 12:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 12:46:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (345.91 KB, image/png)
2012-04-05 03:48 EDT, Jakub Dorňák
no flags Details

  None (edit)
Description Jakub Dorňák 2012-04-05 03:48:33 EDT
Created attachment 575309 [details]
screenshot

Description of problem:
When using SM GUI auto-subscribe doesnt work.


Version-Release number of selected component (if applicable):
RHEL6.3-20120329.0
SAM-2012-03-31.1


How reproducible:
On fresh installed system setup SM (/etc/rhsm/rhsm.conf) to use SAM.

Steps to Reproduce:
1. run subscription-manager-gui
2. click on the "Register" button
3. fill in the name and password
4. leave the "skip ..." checkbox unchecked

  
Actual results:
Message window saying:
Unable to auto-subscribe, server does not support service levels.


Expected results:
System is registered and auto-subscribed to appropriate pool.

Additional info:
Screenshot attached.
Comment 2 RHEL Product and Program Management 2012-04-05 03:53:24 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 3 RHEL Product and Program Management 2012-04-05 04:13:42 EDT
Thank you for your bug report. This issue was evaluated for inclusion
in the current release of Subscription Asset Manager (SAM). Unfortunately,
we are unable to address this request. Because we are in the final stages
of development in the current release, only significant, release-blocking
issues involving serious regressions and data corruption can be considered.

If you believe this issue meets the release blocking criteria as defined and
communicated to you by your Red Hat Support representative, please ask
your representative to file this issue as a blocker for the current release.
Otherwise, ask that it be evaluated for inclusion in the next release of SAM.
Comment 4 Tomas Strachota 2012-05-07 05:57:45 EDT
I couldn't reproduce the problem. I believe it is fixed in katello-headpin-0.2.6-1
We added the support for service levels on katello side some time ago.

Jakub, could you please retest the issue with the latest SAM build?
Comment 5 Jakub Dorňák 2012-05-07 07:47:12 EDT
I am sorry, but I can't, since there is a blocker (https://bugzilla.redhat.com/show_bug.cgi?id=819013).
Comment 6 Tom McKay 2012-05-18 10:02:26 EDT
See 818564 for fix details

Note You need to log in before you can comment on or make changes to this bug.