Bug 81011 - kernel doesn't have a dependency on /etc/mtab and /etc/fstab
Summary: kernel doesn't have a dependency on /etc/mtab and /etc/fstab
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Erik Troan
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-03 13:55 UTC by Dries Verachtert
Modified: 2007-04-18 16:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-06 06:04:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dries Verachtert 2003-01-03 13:55:04 UTC
Description of problem: 
When you install the kernel rpm without having a /etc/fstab and /etc/mtab yet, the post-install 
script has problems: 
warning: can't open /etc/mtab: No such file or directory 
warning: can't open /etc/mtab: No such file or directory 
awk: cmd. line:2: fatal: cannot open file `/etc/fstab' for reading (No such file or directory) 
ls: : No such file or directory 
/sbin/mkinitrd: line 434: [: : integer expression expected 
awk: cmd. line:2: fatal: cannot open file `/etc/fstab' for reading (No such file or directory) 
awk: cmd. line:2: fatal: cannot open file `/etc/fstab' for reading (No such file or directory) 
ext2fs_check_if_mount: No such file or directory while determining whether /dev/loop2 is 
mounted. 
warning: can't open /etc/fstab: No such file or directory 
awk: cmd. line:2: fatal: cannot open file `/etc/fstab' for reading (No such file or directory) 
/sbin/new-kernel-pkg: line 63: [: ==: unary operator expected 
 
Version-Release number of selected component (if applicable): 
tested with kernel-2.4.18-19.8.0.i686.rpm + needed rpms to satisfy the dependencies of this 
kernel package from redhat 8.0 + updates 
 
How reproducible: 
every time. 
I can provide you with a script if you wish. 
 
Steps to Reproduce: 
1. start the installation of a new rootfilesystem in a directory (for example for creating a  
bootable cd): ROOT =/tmp/root , mkdir -p $ROOT/var/lib/rpm ; rpm --initdb --root=${ROOT}  
2. install all rpms needed to satisfy the dependencies of kernel  
3. forget to initialize the /etc/fstab and /etc/mtab 
4. install the kernel rpm  
     
Actual results: 
A warning of rpm telling me that the kernel rpm needs the /etc/mtab and /etc/fstab files. 
 
Expected results: 
Errors in the post-install script (see description) 
 
Additional info: 
I've set the severity to low because normal users will never notice this.

Comment 1 Jeremy Katz 2003-01-06 06:04:24 UTC
These files aren't owned by any package and are assumed to be created before you
begin system installation.


Note You need to log in before you can comment on or make changes to this bug.