Bug 810112 - liveusb-creator-written LiveCDs are not UEFI bootable
Summary: liveusb-creator-written LiveCDs are not UEFI bootable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: liveusb-creator
Version: 18
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: https://fedoraproject.org/wiki/Common...
Depends On:
Blocks: F19Beta, F19BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2012-04-05 08:11 UTC by Adam Williamson
Modified: 2016-09-20 02:43 UTC (History)
14 users (show)

Fixed In Version: liveusb-creator-3.12.0-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-10 07:11:12 UTC


Attachments (Terms of Use)
grub (150.06 KB, image/jpeg)
2012-11-22 12:02 UTC, Kamil Páral
no flags Details
boot (293.61 KB, image/jpeg)
2012-11-22 12:02 UTC, Kamil Páral
no flags Details
working version of EFI/BOOT/grub.cfg (830 bytes, text/plain)
2012-12-30 13:18 UTC, Manfred Spraul
no flags Details

Description Adam Williamson 2012-04-05 08:11:00 UTC
I wrote F17 Beta RC3 desktop live to a USB stick with liveusb-creator. It boots fine via BIOS, but if booted via EFI, it just boots to a grub prompt.

Comment 1 Luke Macken 2012-04-05 17:02:45 UTC
This only works using 'livecd-iso-to-disk --format --efi', right? The liveusb-creator currently doesn't support formatting devices with GPT partition tables, but it needs to.

Comment 2 Adam Williamson 2012-04-06 05:03:59 UTC
luke: yup, with l-i-t-d it works if you pass --efi. The images are also supposed to be EFI bootable if dd'ed, but that's broken at present.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 3 Adam Williamson 2012-11-22 11:54:33 UTC
This is still the case as of F18, luc has no UEFI support.

Comment 4 Kamil Páral 2012-11-22 12:02:06 UTC
Bumping to F18. I tried F18 Beta RC1 Live x86_64 with liveusb-creator-3.11.7-1.fc17.noarch.

It boots in BIOS mode, but it doesn't boot in UEFI mode. The path to kernel and initrd is wrong, it should be /syslinux/ instead of /isolinux/. See grub.jpg.

Also if I change the kernel path, it doesn't find the root partition. See boot.jpg. Instead of /dev/disk/by-label/Fedora-* I copied the root= argument from BIOS mode grub (root=live:UUID=BE37-6C98) and it booted OK.

Marking as CommonBugs, we should document that liveusb-creator can't create UEFI images.

Comment 5 Kamil Páral 2012-11-22 12:02:25 UTC
Created attachment 649741 [details]
grub

Comment 6 Kamil Páral 2012-11-22 12:02:44 UTC
Created attachment 649742 [details]
boot

Comment 7 admin 2012-11-29 00:16:53 UTC
@Kamil: Have you being successfully able to boot on UEFI with your changes?

Comment 8 Kamil Páral 2012-11-29 09:36:51 UTC
admin: Yes, after making all the changes it booted OK. See third paragraph in comment 4.

Comment 9 Manfred Spraul 2012-12-28 15:20:40 UTC
Any progress on this bug?
I can confirm that a Fedora 18 Beta boots if the grub settings are changed:
- syslinux instead of isolinux
- The actual label instead of Fedora-18-....

Computer: 
Lenovo Ideapad S400

Comment 10 schaefi 2012-12-30 01:35:13 UTC
I still have problems to boot with UEFI. Here the details ...

Hardware: HP ENVY 6-1160ez
-          Chip: Intel® Core™ i5-3317U (1,7 GHz, 3 MB L3-Cache)
-          RAM: 8 GB DDR3
-          Disk: 500 GB SATA (5400 U/min) + 32 GB mSATA SSD
-          Display: HD BrightView LED-Display mit einer Diagonalen von 39,6 cm (15,6") und Hintergrundbeleuchtung (1366 x 768)
-          Graphic: Intel HD Graphics 4000 (bis zu 1,65 GB)
-          Details: http://www8.hp.com/h20195/v2/GetPDF.aspx/c03548945.pdf
-          the Laptop comes with pre-installed Windows 8 and UEFI

I generated a bootable USB-Stick with another computer under Fedora 17 with:
    "livecd-iso-to-disk --format --reset-mbr --efi Fedora-18-Beta-x86_64-Live-Desktop.iso /dev/sdg"
whereas /dev/sdg is the unmounted USB stick

I then inserted the USB stick in the HP-Laptop and booted:
-> ESC to enter the startup menu
-> press F9 to enter the Boot Manager
-> select: USB Hard Drive (UEFI) - LaCie iamaKey
Then an error message follows: 
"Selected boot image did not Authenticate. Press <Enter> to Continue."

What went wrong? Anybody any idea?

Comment 11 Manfred Spraul 2012-12-30 13:18:31 UTC
Created attachment 670402 [details]
working version of EFI/BOOT/grub.cfg

required changes for my USB stick for an EFI boot.
(lenovo S400, no secure boot)

Note: I'm not sure if the label "LIVE" always applies.
If it doesn't boot: do

    # ls /dev/disk/by-label/

and check the label of your USB stick.

Comment 12 Manfred Spraul 2012-12-30 13:23:21 UTC
@schaefi:
Does the message appear immediately or is the GRUB screen shown first?
(on the grub screen you can select boot fedora / verify disk, ...)

If it happens after the grub screen:
Could you try the modification of /EFI/BOOT/grub.cfg?

If it happens before grub is loaded:
Then it's probably related to secure boot, I think you should open a seperate bug report.

Comment 13 schaefi 2012-12-30 14:43:28 UTC
@Manfred:
the error appears before grub is loaded. I do not get to the grub screen.

Comment 14 schaefi 2012-12-30 15:27:47 UTC
@Manfred
as recommended I have filed a seperate bug report with a bit more derails:
https://bugzilla.redhat.com/show_bug.cgi?id=890840

Comment 15 Chris Murphy 2013-01-28 01:57:58 UTC
What's the status of getting this bug fixed? It looks like it's very close to being UEFI boot capable, it's just inserting a couple of wrong kernel parameters into the grub.cfg.

Comment 16 Chris Murphy 2013-01-28 02:01:45 UTC
FWIW it's still a bug with 3.11.7-2.fc18

Comment 17 markusN 2013-02-19 22:30:40 UTC
FWIW:
On a new ASUS notebook, I got the USB stick based netinstall iso booted with this trick (change the label to LIVE in the boot options during the USB boot:

https://fedorahosted.org/liveusb-creator/ticket/809

Comment 18 Paolo Leoni 2013-03-14 18:32:51 UTC
It's still a bug with 3.11.7-2.fc18. Live usb created with that version failed to start.

Comment 19 GuiXin 2013-04-06 15:01:14 UTC
i think i encounter this bug too.
after grub view 
show the message:
error: file '/isolinux/vmlinuz0' not found
error: you need to load the kernel first

Is there other way to make live usb for F18?

Comment 20 markusN 2013-04-06 15:11:10 UTC
(In reply to comment #19)
> Is there other way to make live usb for F18?

For a workaround, see comment #17

Comment 21 GuiXin 2013-04-06 15:32:25 UTC
how to change boot option to
"hdinst.stage2:LABEL=LIVE"

is there in a configure file?

Comment 22 markusN 2013-04-06 17:12:39 UTC
(In reply to comment #21)
> how to change boot option to
> "hdinst.stage2:LABEL=LIVE"

At boot time, you can edit the configuration (see
help text when booting). The editor is a bit rudimentary.

But apparently fixed upstream:
https://fedorahosted.org/liveusb-creator/ticket/809#comment:2

Comment 23 GuiXin 2013-04-10 13:27:57 UTC
thx
it's also work on dvd iso when i tried it.
it can't use the software source in the usb, although it can boot.
So, i change the software source to closest mirror

i think it's better use netinsall iso for usb

Comment 24 Fedora Update System 2013-04-22 21:10:44 UTC
liveusb-creator-3.11.8-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/liveusb-creator-3.11.8-1.fc18

Comment 25 Fedora Update System 2013-04-22 21:11:23 UTC
liveusb-creator-3.11.8-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/liveusb-creator-3.11.8-1.fc19

Comment 26 Fedora Update System 2013-04-23 02:59:18 UTC
Package liveusb-creator-3.11.8-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liveusb-creator-3.11.8-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-6337/liveusb-creator-3.11.8-1.fc19
then log in and leave karma (feedback).

Comment 27 Fedora Update System 2013-04-26 15:04:03 UTC
liveusb-creator-3.11.8-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/liveusb-creator-3.11.8-2.fc19

Comment 28 Fedora Update System 2013-05-01 04:27:55 UTC
liveusb-creator-3.11.8-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2013-05-02 03:54:34 UTC
liveusb-creator-3.11.8-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 30 Kamil Páral 2013-05-21 12:41:53 UTC
Reopening. This is still broken, I just tested liveusb-creator-3.11.8-1.fc18 with F19 Beta RC2.

The boot menu contains references to /syslinux/vmlinuz and /syslinux/initrd.img, while the files are named /syslinux/vmlinuz0 and /syslinux/initrd0.img.

Also, a number of important kernel options are missing, most importantly:
root=live:CDLABEL=LIVE rd.live.image

And probably also quite important:
rootfstype=vfat ro rd.luks=0 rd.md=0 rd.dm=0

Proposing as Beta blocker, because:
"All release-blocking images must boot in their supported configurations. 
Release-blocking live and dedicated installer images must boot when written to optical media of an appropriate size (if applicable) and when written to a USB stick with any of the officially supported methods."
http://fedoraproject.org/wiki/Fedora_19_Beta_Release_Criteria#Release-blocking_images_must_boot

It seems that LUC+UEFI is intended to be an officially supported method now.

Comment 31 Luke Macken 2013-05-21 17:54:27 UTC
I just tested F19 Beta RC2 with liveusb-creator-3.11.8-1.fc18.noarch on my iMac8,1 and MacBookAir5,4 and I cannot reproduce this issue. My boot config references vmlinuz0 and initrd0.img, and has the appropriate kernel options: "root=live:LABEL=LIVE rw rd.live.image rd.live.overlay=LABEL=LIVE quiet rhgb"

Comment 32 Luke Macken 2013-05-21 18:00:48 UTC
Kamil, could you check to see if there are any warnings or errors in the `liveusb-creator -v` output? Could you also try with a freshly formatted stick?

Comment 33 Adam Williamson 2013-05-21 18:06:10 UTC
I'd be -1 blocker on this anyhow - a) it's kinda moving the goalposts, if we'd actually got luc working and then later broke it then that might be worse, and b) the problem is probably in luc itself not the F19 images, so holding the f19 release for it probably isn't necessary.

Comment 34 Chris Murphy 2013-05-21 19:33:48 UTC
If the problem isn't with the image, I'd say it's not release blocking. Holding up the release ends up being collective punishment, and doesn't really aid in fixing the real problem. So I'd be -1 blocker for beta and final if it's a LUC problem.

Comment 35 Kamil Páral 2013-05-22 08:35:31 UTC
(In reply to Luke Macken from comment #31)
> I just tested F19 Beta RC2 with liveusb-creator-3.11.8-1.fc18.noarch on my
> iMac8,1 and MacBookAir5,4 and I cannot reproduce this issue. My boot config
> references vmlinuz0 and initrd0.img, and has the appropriate kernel options:
> "root=live:LABEL=LIVE rw rd.live.image rd.live.overlay=LABEL=LIVE quiet rhgb"

I tried:
1) running liveusb-creator on a stick with existing (previous) live system -> bad config
2) running liveusb-creator --reset-mbr on a stick with existing (previous) live system -> bad config
3) running liveusb-creator on a zeroed stick -> bug 965973
4) running liveusb-creator on a zeroed stick with a new fresh FAT partition -> works

So, you're right, it "works", but not quite. Usually I fall victim to the bad user interface, where I forget to specify --reset-mbr and the interface doesn't clearly alert me to do it (heck, it should do it by default). But this time even --reset-mbr didn't help.

Closing this bug again, the original problem is fixed. We should follow up in a different bug wrt to bootloader issues.

Comment 36 Phil V 2013-06-17 02:27:18 UTC
Sorry, but I just used 'fedora live usb creator' on an updated F17 system and obtained the original errors. In what way is the original problem fixed?

Comment 37 Phil V 2013-06-17 02:51:45 UTC
More importantly, what's a working solution for F17, the previous release, since that is still supposed to be supported?

Comment 38 Adam Williamson 2013-06-17 04:14:59 UTC
Luke, do you want to send 3.11.8 to f17?

Phil: the bug was filed against F18. It's fixed in relation to F18.

Comment 39 Fedora Update System 2013-10-17 22:58:56 UTC
liveusb-creator-3.12.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/liveusb-creator-3.12.0-1.fc19

Comment 40 Fedora Update System 2013-10-17 22:59:49 UTC
liveusb-creator-3.12.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/liveusb-creator-3.12.0-1.fc18

Comment 41 Fedora Update System 2013-10-17 23:00:45 UTC
liveusb-creator-3.12.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/liveusb-creator-3.12.0-1.fc20

Comment 42 Fedora Update System 2013-10-19 00:10:19 UTC
Package liveusb-creator-3.12.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing liveusb-creator-3.12.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19384/liveusb-creator-3.12.0-1.fc20
then log in and leave karma (feedback).

Comment 43 Fedora Update System 2013-11-10 07:11:12 UTC
liveusb-creator-3.12.0-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 44 Fedora Update System 2013-12-12 02:56:30 UTC
liveusb-creator-3.12.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 45 Fedora Update System 2013-12-12 02:57:42 UTC
liveusb-creator-3.12.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.