Bug 810113 - IOException: Partition(s) 2 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use. As a result, the old partition(s) will remain in use. You should reboot now before making further
IOException: Partition(s) 2 on /dev/sda have been written, but we have been u...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
x86_64 Unspecified
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
abrt_hash:ab2033068cf0a1109cd0a042797...
:
Depends On:
Blocks: 782468
  Show dependency treegraph
 
Reported: 2012-04-05 04:13 EDT by Alexander Todorov
Modified: 2012-07-19 07:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-19 07:26:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb-C3M01a (336.24 KB, text/plain)
2012-04-05 04:13 EDT, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2012-04-05 04:13:26 EDT
libreport version: 2.0.7
executable:     /usr/bin/python
hashmarkername: anaconda
kernel:         3.2.1-0.9.el7.x86_64
product:        Red Hat Enterprise Linux
reason:         IOException: Partition(s) 2 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.
time:           Thu 05 Apr 2012 04:12:57 AM EDT
version:        7.0

anaconda-tb-C3M01a: Text file, 344305 bytes

description:
:The following was filed automatically by anaconda:
:anaconda 16.25.4 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/parted/disk.py", line 213, in commit
:    return self.__disk.commit()
:  File "/usr/lib64/python2.7/site-packages/parted/decorators.py", line 32, in new
:    ret = fn(*args, **kwds)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/disklabel.py", line 263, in commit
:    self.partedDisk.commit()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/formats/disklabel.py", line 242, in create
:    self.commit()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 433, in execute
:    options=self.device.formatArgs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 316, in processActions
:    action.execute(intf=self.intf)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 385, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/packages.py", line 122, in turnOnFilesystems
:    anaconda.storage.doIt()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 373, in dispatch
:    self.dir = self.steps[self.step].target(self.anaconda)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 88, in return_false
:    func(*args, **kwargs)
:IOException: Partition(s) 2 on /dev/sda have been written, but we have been unable to inform the kernel of the change, probably because it/they are in use.  As a result, the old partition(s) will remain in use.  You should reboot now before making further changes.
Comment 1 Alexander Todorov 2012-04-05 04:13:30 EDT
Created attachment 575314 [details]
File: anaconda-tb-C3M01a
Comment 2 Alexander Todorov 2012-04-05 04:15:20 EDT
My ks.cfg is:

clearpart --all --initlabel 
# Disk partitioning information
part biosboot --fstype="biosboot" --size=1
part /boot --asprimary --fstype="ext3" --size=200 --label=BOOT
part swap --fstype="swap" --recommended --label=SWAP
part /multi-stage --fstype="ext3" --size=100 --label=MULTISTAGE
part raid.01 --grow --size=2048
part raid.02 --grow --size=2048
raid / --device=0 --fstype="ext3" --level=RAID0 raid.01 raid.02



Notice the --grow for RAID members. I wanted to check if RHEL7 will allow it (I think not). The bug however doesn't seem related to this.
Comment 3 Jesse Keating 2012-07-18 17:36:00 EDT
Can you try with the more recent images?  We've had a fair amount of churn.

Note You need to log in before you can comment on or make changes to this bug.