Bug 810136 - preupgrade broken with 17 Beta RC3 (17.18): 'no suitable images', 'Unable to process initqueue', '/dev/root does not exist'
preupgrade broken with 17 Beta RC3 (17.18): 'no suitable images', 'Unable to ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-04-05 05:01 EDT by Adam Williamson
Modified: 2012-05-30 03:11 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-17.20-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-05 15:40:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
kickstart and grub config from the attempt (3.21 KB, text/plain)
2012-04-05 05:01 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2012-04-05 05:01:57 EDT
Created attachment 575326 [details]
kickstart and grub config from the attempt

I tried to test preupgrade with anaconda 17.18 (Beta RC3). I downloaded releases.txt and edited it to have baseurl=http://dl.fedoraproject.org/pub/fedora/linux/development/17/x86_64/os/ to force the use of a known up-to-date mirror, after releng had done a compose with the new anaconda/lorax.

After reboot, I got a failure which looks different from the others reported so far, so I think this is with 17.18 :( hard to tell though as it doesn't make it past dracut.

I see these errors at boot:

dracut Warning: no suitable images
dracut Warning: Unable to process initqueue
dracut Warning: /dev/root does not exist

Dropping to debug shell.

At the shell I can see /dev/vda2 is mounted at /run/install/repo . It is the /boot partition of the installed system, I see the /upgrade directory inside it.

cat /proc/cmdline gives:

BOOT_IMAGE=/upgrade/vmlinuz preupgrade repo=hd::/var/cache/yum/preupgrade ks=hd:UUID=f9f8667a-5806-41be-a96d-93bbac0334e4:/upgrade/ks.cfg stage2=hd:UUID=f9f8667a-5806-41be-a96d-93bbac0334e4:/upgrade/squashfs.img

I'm attaching the ks.cfg and grub.cfg written by preupgrade prior to reboot. I'm leaving the VM running in the dracut shell in case any more info is desired.
Comment 1 Adam Williamson 2012-04-05 05:02:13 EDT
proposing as Beta blocker. :(
Comment 2 Richard Hughes 2012-04-05 05:52:14 EDT
You know, this feels an awful lot like "whack a mole" as there doesn't seem to be any documented stable anaconda interface for preupgrade to use.
Comment 3 Martin Krizek 2012-04-05 07:02:35 EDT
I reproduced it in KVM x86_64. Anaconda 17.18 (F17 Beta RC3).
Comment 4 eric@christensenplace.us 2012-04-05 10:50:05 EDT
I, too, am seeing this error trying to upgrade to F17.
Comment 5 Adam Williamson 2012-04-05 15:40:27 EDT
OK, so it turns out that this is simply another case of #810005. Moving discussion there.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 810005 ***
Comment 6 Fedora Update System 2012-04-06 09:58:19 EDT
anaconda-17.19-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.19-1.fc17
Comment 7 Fedora Update System 2012-04-10 00:14:09 EDT
anaconda-17.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.20-1.fc17
Comment 8 Fedora Update System 2012-04-11 13:22:07 EDT
anaconda-17.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Tapani Mattila 2012-05-29 15:50:22 EDT
Still there when trying to preupgrade to stable F17.
Comment 10 Adam Williamson 2012-05-30 03:10:36 EDT
No it isn't. There is no general issue with preupgrade at this point. Seeing '/dev/root does not exist' does not mean you are hitting this bug (or any other bug where that error message happens to be mentioned). It's an extremely generic error. Virtually any kind of failure at the dracut stage will wind up showing up as '/dev/root does not exist'.
Comment 11 Adam Williamson 2012-05-30 03:11:50 EDT
To expand - if you're having a problem then the problem you're having is something specific to your particular configuration. It is not this bug, because this bug was a general showstopper which prevented any attempt to use preupgrade, and we have explicitly verified that it no longer exists. I'm not saying you're not hitting a bug. I'm saying you're not hitting _this_ bug. Please file a new one, with a lot more detail about your configuration. Thanks.

Note You need to log in before you can comment on or make changes to this bug.