Bug 810226 - Cursor invisible in X in a KVM when using qxl video driver but VNC viewer
Cursor invisible in X in a KVM when using qxl video driver but VNC viewer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks: F17Target-kde
  Show dependency treegraph
 
Reported: 2012-04-05 08:23 EDT by Martin Krizek
Modified: 2013-01-09 07:00 EST (History)
22 users (show)

See Also:
Fixed In Version: qemu-1.0-17.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 00:48:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Krizek 2012-04-05 08:23:29 EDT
Description of problem:
Using qxl in virt-manager, the mouse cursor is not displayed in KDE in Fedora 17 Beta RC3. However, once one logs out of the KDE session, the cursor appears and is visible from that point also after logging into the KDE session again.

Version-Release number of selected component (if applicable):
0.0.22-0.fc17.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Choose qxl in virt-manager
2. Boot and log into KDE
3.
  
Actual results:
The mouse cursor is not visible

Expected results:
The mouse cursor is visible

Additional info:
Comment 1 Martin Krizek 2012-04-05 08:24:53 EDT
Proposing as F17 Beta blocker, since it makes KDE desktop unusable.
Comment 2 Jaroslav Reznik 2012-04-05 10:40:04 EDT
I can't reproduce it as my virt-manager does not want to grab mouse - any hint here?
Comment 3 Adam Williamson 2012-04-05 11:08:04 EDT
I can't reproduce with qxl/spice, works fine.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2012-04-05 11:09:33 EDT
reproduced with qxl/vnc, which is never a default config.
Comment 5 Adam Williamson 2012-04-05 11:37:29 EDT
Updating topic with info provided by bcl.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Daniel Berrange 2012-04-05 11:47:19 EDT
> reproduced with qxl/vnc, which is never a default config.

We can't assume that in general - since qxl provides basic VGA capabilities when used without SPICE, it is perfectly reasonable to use QXL + VNC. So while virt-manager doesn't do this by default, it is acceptable for apps to enable QXL by default.
Comment 7 Cole Robinson 2012-04-05 12:50:02 EDT
Mentioned by adamw in IRC, upstream patch here:

http://patchwork.freedesktop.org/patch/9198/
Comment 8 Daniel Berrange 2012-04-05 12:58:38 EDT
Changing to QEMU on basis of Cole's URL
Comment 9 Adam Williamson 2012-04-06 00:10:13 EDT
dberrange: as far as blocker status goes, we mostly consider fedora's 'supported vm stack', which is taken to be virt-manager / libvirt / qemu / kvm.

Discussed at 2012-04-05 go/no-go meeting - http://meetbot.fedoraproject.org/fedora-meeting-1/2012-04-05/gono-go_continuation_f17_beta_rc3_part_two_or_three.2012-04-05-15.00.html . We agreed that as the qxl/vnc combination has never been default in the supported stack (see above), it's easy to 'work around' this bug by switching to cirrus/vnc or qxl/spice, and the bug is not in the guest but the host (and so we don't gain much by fixing it in the release images) this bug is rejected as a blocker. It is not accepted as NTH, for the reason that fixing it in the images doesn't actually change much. Anyone running a host can be expected to have the latest updates on the host.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Fedora Update System 2012-04-20 09:29:03 EDT
qemu-1.0-15.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qemu-1.0-15.fc17
Comment 11 Fedora Update System 2012-04-21 17:00:35 EDT
Package qemu-1.0-15.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing qemu-1.0-15.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6290/qemu-1.0-15.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-04-23 06:30:19 EDT
qemu-1.0-17.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/qemu-1.0-17.fc17
Comment 13 Martin Krizek 2012-04-23 11:07:33 EDT
Seems to be fixed, can't reproduced it anymore (yum update with updates-testing on, F17 host).
Comment 14 Fedora Update System 2012-05-02 00:48:01 EDT
qemu-1.0-17.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.