This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 810239 - selinux-policy does not always have a correct label for files in /var/log/ which were processed by logrotate before
selinux-policy does not always have a correct label for files in /var/log/ wh...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.8
All Linux
low Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On: 809877
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 08:53 EDT by Milos Malik
Modified: 2013-01-07 22:31 EST (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-2.4.6-332.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 809877
Environment:
Last Closed: 2013-01-07 22:31:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2012-04-05 08:53:46 EDT
+++ This bug was initially created as a clone of Bug #809877 +++

Description of problem:
I believe that the problem manifests itself on various log files, not just kerberos* ones

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.4.6-327.el5.noarch
selinux-policy-2.4.6-327.el5.noarch
selinux-policy-devel-2.4.6-327.el5.noarch
selinux-policy-mls-2.4.6-327.el5.noarch
selinux-policy-strict-2.4.6-327.el5.noarch
selinux-policy-minimum-2.4.6-327.el5.noarch

How reproducible:
always

Actual results:
# matchpathcon /var/log/k*
/var/log/kadmind.log    system_u:object_r:kadmind_log_t:s0
/var/log/kadmind.log.1  system_u:object_r:var_log_t:s0
/var/log/kadmind.log.2  system_u:object_r:var_log_t:s0
/var/log/krb5kdc.log    system_u:object_r:krb5kdc_log_t:s0
/var/log/krb5kdc.log.1  system_u:object_r:var_log_t:s0
/var/log/krb5kdc.log.2  system_u:object_r:var_log_t:s0
#

Expected results:
* each file that was processed by logrotate should be labelled the same way as before it was processed by logrotate
Comment 1 RHEL Product and Program Management 2012-04-05 09:07:22 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Miroslav Grepl 2012-07-30 02:57:55 EDT
Fixed in selinux-policy-2.4.6-330.el5
Comment 10 errata-xmlrpc 2013-01-07 22:31:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0060.html

Note You need to log in before you can comment on or make changes to this bug.