Bug 810247 - when closing remote-viewer/virt-viewer while recording audio over spice, remote-viewer segfaults
when closing remote-viewer/virt-viewer while recording audio over spice, remo...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: 6.3
Assigned To: Marc-Andre Lureau
Desktop QE
abrt_hash:696e90a9bb0044db9638b992ebc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 09:10 EDT by David Jaša
Modified: 2012-06-20 08:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:19:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (29.11 KB, text/plain)
2012-04-05 09:10 EDT, David Jaša
no flags Details

  None (edit)
Description David Jaša 2012-04-05 09:10:39 EDT
Created attachment 575406 [details]
backtrace

Description of problem:
when closing remote-viewer/virt-viewer while recording audio over spice, remote-viewer segfaults

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-3.el6.x86_64
spice-gtk-0.11-5.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. open a virt-viewer/remote-viewer connection to guest over spice
2. start audio recording in the guest
3. close virt-viewer/remote-viewer
  
Actual results:
virt-viewer gets segfault

Expected results:
virt-viewer exits cleanly

Additional info:
occurs with connection to both 6.3 and 5.8 hosts

top of backtrace:
#0  memcpy () at ../sysdeps/x86_64/memcpy.S:196
196             movq    %rax,   (%rdi)

Thread 1 (Thread 0x7fa0955e9940 (LWP 13292)):
#0  memcpy () at ../sysdeps/x86_64/memcpy.S:196
No locals.
#1  0x0000003aa12271b1 in spice_record_send_data (channel=0x144d7a0 [SpiceRecordChannel], data=<value optimized out>, bytes=1760, time=<value optimized out>) at /usr/include/bits/string3.h:52
        n = 960
        frame_size = <value optimized out>
        msg = <value optimized out>
        frame = <value optimized out>
        rc = 0x144e1c0
        p = {time = 0, data = 0x0, data_size = 0}
        celt_buf = 0x7fff7a926ae0 ""
        __PRETTY_FUNCTION__ = "spice_record_send_data"
#2  0x0000003aa12aea7a in stream_read_callback (s=0x307f670, length=1760, data=<value optimized out>) at spice-pulse.c:455
        snddata = 0x7fa07a226000
        pulse = <value optimized out>
        p = 0x12f0f10
        __PRETTY_FUNCTION__ = "stream_read_callback"
#3  0x0000003a9d00f103 in pstream_memblock_callback (p=<value optimized out>, channel=<value optimized out>, offset=0, seek=PA_SEEK_RELATIVE, chunk=0x7fff7a926cb0, userdata=0x1439760) at pulse/context.c:376
        l = <value optimized out>
        c = 0x1439760
        s = 0x307f670
        __func__ = "pstream_memblock_callback"
        __PRETTY_FUNCTION__ = "pstream_memblock_callback"


other packages on which virt-viewer depends:
atk-1.28.0-2.el6.x86_64
bash-4.1.2-8.el6.x86_64
cairo-1.8.8-3.1.el6.x86_64
fontconfig-2.8.0-3.el6.x86_64
freetype-2.3.11-6.el6_1.8.x86_64
glibc-2.12-1.77.el6.i686
glibc-2.12-1.77.el6.x86_64
glib2-2.22.5-7.el6.x86_64
gnutls-2.8.5-4.el6_2.2.x86_64
gtk-vnc-0.3.10-3.el6.x86_64
gtk2-2.18.9-10.el6.x86_64
chkconfig-1.3.49.3-2.el6.x86_64
libvirt-client-0.9.10-9.el6.x86_64
libxml2-2.7.6-4.el6_2.4.x86_64
openssh-clients-5.3p1-75.el6.x86_64
pango-1.28.1-6.el6.x86_64
spice-glib-0.11-5.el6.x86_64
Comment 1 Daniel Berrange 2012-04-05 09:16:50 EDT
The stack trace ends up in spice-gtk code, so re-assigning
Comment 2 Marc-Andre Lureau 2012-04-05 22:08:34 EDT
Fix sent to spice ML
Comment 6 Marc-Andre Lureau 2012-04-20 09:10:20 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No documentation needed.
Comment 9 errata-xmlrpc 2012-06-20 08:19:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0767.html

Note You need to log in before you can comment on or make changes to this bug.