Bug 810273 - lvmetad runs as initrc_t
lvmetad runs as initrc_t
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 832330
  Show dependency treegraph
 
Reported: 2012-04-05 10:01 EDT by Milos Malik
Modified: 2012-09-24 02:57 EDT (History)
1 user (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-146.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 08:33:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0780 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2012-06-19 16:34:59 EDT

  None (edit)
Description Milos Malik 2012-04-05 10:01:44 EDT
Description of problem:


Version-Release number of selected component (if applicable):
selinux-policy-doc-3.7.19-143.el6.noarch
selinux-policy-3.7.19-143.el6.noarch
selinux-policy-mls-3.7.19-143.el6.noarch
selinux-policy-minimum-3.7.19-143.el6.noarch
selinux-policy-targeted-3.7.19-143.el6.noarch

How reproducible:
always

Steps to Reproduce:
# run_init service lvm2-lvmetad status
Authenticating root.
Password: 
lvmetad is stopped
# run_init service lvm2-lvmetad start
Authenticating root.
Password: 
Starting LVM metadata daemon:                              [  OK  ]
  Cannot proceed since lvmetad is not active.
# run_init service lvm2-lvmetad status
Authenticating root.
Password: 
lvmetad (pid  8724) is running...
# ps -efZ | grep lvmetad
system_u:system_r:initrc_t:s0   root      8724     1  0 15:59 ?        00:00:00 lvmetad
unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 root 8739 5940  0 15:59 pts/0 00:00:00 grep lvmetad
# 

Actual results:
* lvmetad runs as initrc_t

Expected results:
* lvmetad runs in its own SELinux domain
Comment 1 Miroslav Grepl 2012-04-06 08:31:32 EDT
Looks somethin which should be just labeled with lvm_exec_t. 

Milos, could you test it

$ chcon -t lvm_exec_t /sbin/lvmetad
Comment 2 Milos Malik 2012-04-06 09:08:41 EDT
It seems to run well with that label.
Comment 5 errata-xmlrpc 2012-06-20 08:33:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0780.html

Note You need to log in before you can comment on or make changes to this bug.