Bug 810287 - "Add Permission to User" window doesn't display user list automatically when it pop-up
"Add Permission to User" window doesn't display user list automatically when...
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Einav Cohen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 10:24 EDT by Avihai Shoham
Modified: 2016-01-28 16:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 22:04:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-shot (16.21 KB, image/png)
2012-04-05 10:24 EDT, Avihai Shoham
no flags Details

  None (edit)
Description Avihai Shoham 2012-04-05 10:24:00 EDT
Created attachment 575442 [details]
screen-shot

when i clicked on add permission to user the window was pop-up but there was no list of the user.

the lists displayed after i clicked on "GO" button



Steps to Reproduce:
1. add permission to user
2. you will see a blank pane 
3. click on "GO" button
  

Expected results:

list of the existence user will be display when trying to add permission to user

see attached screen-shot
Comment 1 Andrew Cathrow 2012-04-10 22:04:04 EDT
This is by design and I believe the design is sound.
Firstly the list of all users could be huge, secondly we need to support multiple domains, so which do we pick? 
And finally we don't want to take any shortcuts when assigning permissions - I'd rather the admin explicitly search for user.

Note You need to log in before you can comment on or make changes to this bug.