Bug 810348 - "error: file not found" after booting kernel
"error: file not found" after booting kernel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 12:39 EDT by Christian Schramm
Modified: 2012-07-04 11:11 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 19:52:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Schramm 2012-04-05 12:39:16 EDT
Description of problem:
After upgrading F16 to F17 Beta (and hitting #810346), every time I boot I get the message "error: file not found" 3 times. Then I get asked to hit a key, and after that booting continues as expected.

Version-Release number of selected component (if applicable):
GRUB2 1.99-19

How reproducible:
always

Steps to Reproduce:
1. boot
2.
3.
  
Actual results:
The following error is produced:
----
error: file not found
error: file not found
error: file not found

Hit a key to continue ...
----

(Wording might not be totally correct here.)

Expected results:
No error is produced.

Additional info:
Recreating grub2 configuration via "grub2-mkconfig -o /boot/grub2/grub.conf" does not help.
Comment 1 Michel Alexandre Salim 2012-04-11 05:04:57 EDT
Same here. When I first upgraded to F17 I did not have this problem, so this must be a recent regression. It seems to start occurring around the time Grub2 starts displaying only one Linux entry (and hiding the other kernels under "Advanced Linux configuration")
Comment 2 Michel Alexandre Salim 2012-04-11 05:16:02 EDT
Problem is still present with the latest grub2-2.0-0.22.fc17.x86_64 from Koji.
Comment 3 Mads Kiilerich 2012-04-17 19:32:33 EDT
Have you tried running
grub2-install /dev/sda
(or wherever your boot loader is installed)?

Try to run 
find /boot/grub2 | sort > before
and compare that with the content after.

I guess the problem is that grub2-mkconfig references the new all_video module that won't be available before it has been installed.
Comment 4 Adam Williamson 2012-04-17 19:52:03 EDT
This is NOTABUG, because you chose 'skip bootloader configuration' at upgrade time (see 810346).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Christian Schramm 2012-04-18 04:22:59 EDT
Running "grub2-install /dev/sda"  solves the problem, thank you! The main difference in "find /boot/grub2 | sort" is that after grub2-install the .mod files are installed in a subdirectory "i386-pc" instead of straight in the grub2 directory.
Comment 6 Jonathan Watt 2012-06-05 05:23:52 EDT
(In reply to comment #4)
> This is NOTABUG, because you chose 'skip bootloader configuration' at
> upgrade time

I also ran into bug 810346 doing a preupgrade from 16 -> 17, and after fixing it with 'sudo grub2-mkconfig -o /boot/grub2/grub.cfg' I also ran into this bug. I'm not sure why this is NOTABUG, since I for one did not do anything other than accept the preupgrade defaults. If 'skip bootloader configuration' is a default, than that itself would seem to be a bug.
Comment 7 Mads Kiilerich 2012-06-05 07:19:36 EDT
(In reply to comment #6)
> (In reply to comment #4)
> > This is NOTABUG, because you chose 'skip bootloader configuration' at
> > upgrade time

For the record: that choice is unfortunately done automatically by upgrade - see 827987.

> I also ran into bug 810346 doing a preupgrade from 16 -> 17, 

No; bug 810346 was for usb install - not for preupgrade.

> and after
> fixing it with 'sudo grub2-mkconfig -o /boot/grub2/grub.cfg' I also ran into
> this bug.

You got the same symptoms - not necessarily the same problem.

This report is a bit unclear and doesn't mention the installation method. It is probably not preupgrade and your problem is probably different. 

> I'm not sure why this is NOTABUG, since I for one did not do
> anything other than accept the preupgrade defaults. If 'skip bootloader
> configuration' is a default, than that itself would seem to be a bug.

Other installation methods has the option of choosing to not install a bootloader - something a power user might need. Choosing that option and not handling it is not a bug.
Comment 8 Jonathan Watt 2012-06-05 08:04:44 EDT
I see. Thanks for clarifying Mads.

Note You need to log in before you can comment on or make changes to this bug.