Bug 810360 - Red Hat Network Account Wording
Red Hat Network Account Wording
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.7
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.8
Assigned To: Chris Duryee
Entitlement Bugs
:
Depends On:
Blocks: 771748 818066 827225
  Show dependency treegraph
 
Reported: 2012-04-05 14:01 EDT by Matt Reid
Modified: 2015-09-27 22:09 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
: 818066 (view as bug list)
Environment:
Last Closed: 2013-01-07 22:49:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Red Hat account firstboot (75.12 KB, image/png)
2012-06-25 11:45 EDT, J.C. Molet
no flags Details
Red Hat account gui (20.42 KB, image/png)
2012-06-25 11:47 EDT, J.C. Molet
no flags Details
red hat account help window (126.01 KB, image/png)
2012-06-28 14:50 EDT, J.C. Molet
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0033 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2013-01-08 03:38:27 EST

  None (edit)
Description Matt Reid 2012-04-05 14:01:49 EDT
Description of problem:
We still refer to Red Hat Network and Red Hat Network account logins within Subscription-Manger. It is my understanding that Portal logins are just considered Red Hat accounts now.

Update: "Red Hat Network account" -> "Red Hat account".

Version-Release number of selected component (if applicable):
rhn-setup-1.0.0-85.el6
subscription-manager*-99.13-1.el6

Steps to Reproduce:
1. Open Subscription-Manager
2a. Look at the system registration window
2b. Alternatively, look at the Entitlement Platform Registration screen in firstboot

Additional info:
Could impact the initial firstboot screens as well. Set Up Software and Choose Server both contain references to RHN and RHN accounts. Not sure if we're ready to axe RHN references entirely, but I think we should update the RHN account terminology at the least.
Comment 2 RHEL Product and Program Management 2012-04-09 17:17:05 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Chris Duryee 2012-05-15 12:26:31 EDT
a9c77ab 1.0.2+
Comment 6 J.C. Molet 2012-06-25 11:45:29 EDT
Created attachment 594228 [details]
Red Hat account firstboot

Testing with versions:
python-rhsm-1.0.2-1.git.2.d5c3d05.el5
subscription-manager-firstboot-1.0.4-1.git.20.0466bff.el5
subscription-manager-gui-1.0.4-1.git.20.0466bff.el5
subscription-manager-1.0.4-1.git.20.0466bff.el5


Attached shows that this has changed in firstboot.
Comment 7 J.C. Molet 2012-06-25 11:47:42 EDT
Created attachment 594229 [details]
Red Hat account gui

Attached shows this has changed in the registration dialog in the gui as well.
Comment 8 J.C. Molet 2012-06-25 11:56:03 EDT
There is an instance of a the old terminology in the gnome help window for subscription-manager-gui:

Projects/subscription-manager|:master ✓ ❯ grep -i -r "Red Hat Network account" . | grep -v \#
./docs/subscription-manager.xml:			For infrastructures which use Red Hat's hosted subscription and content delivery network, all that is required to register the system is the username and password of the Red Hat Network account.


This should be changed... throwing back.
Comment 9 Chris Duryee 2012-06-27 16:20:01 EDT
7c2395200 master 1.0.5+
Comment 10 J.C. Molet 2012-06-28 14:50:31 EDT
Created attachment 595108 [details]
red hat account help window

Tested with versions:
subscription-manager-gui-1.0.5-1.git.31.a3d5de2.el5
subscription-manager-1.0.5-1.git.31.a3d5de2.el5

As shown in screenshot, this has been corrected.

Marking VERIFIED.
Comment 12 errata-xmlrpc 2013-01-07 22:49:40 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.