Bug 810369 - Entitlement Platform Registration Renaming
Entitlement Platform Registration Renaming
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
:
Depends On:
Blocks: 771748 818071 827225
  Show dependency treegraph
 
Reported: 2012-04-05 15:01 EDT by Matt Reid
Modified: 2015-09-27 22:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 818071 (view as bug list)
Environment:
Last Closed: 2013-01-07 22:49:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
subscription registration (89.96 KB, image/png)
2012-06-25 11:41 EDT, J.C. Molet
no flags Details

  None (edit)
Description Matt Reid 2012-04-05 15:01:41 EDT
Description of problem:
"Entitlement Platform Registration" seems like something engineered for RH-eyes-only and is overly complex. I think something like "Subscribe System" is much more intelligible for customers. Out of "Entitlement Platform Registration", only Registration would probably mean anything to them. While they do not necessarily have to Subscribe at that point, it is still the screen where they can opt-out, and their system will be registered either way.

I'm open to other suggestions, but I feel like the current name could be improved.

This only shows in firstboot.
Comment 2 RHEL Product and Program Management 2012-04-09 17:17:00 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 4 Bryan Kearney 2012-06-07 16:28:28 EDT
fixed in master at d28aa3c0427b31c16d6561a539cc2fe883aeb730.
Comment 6 J.C. Molet 2012-06-25 11:41:49 EDT
Created attachment 594227 [details]
subscription registration

subscription-manager-firstboot-1.0.4-1.git.20.0466bff.el5

There appears to be no mention of "Entitlement Platform Registration" anywhere in the source:

xanadu|Projects/subscription-manager|:master ✓ ❯ grep -i -r "Entitlement Platform Registration" . | grep -v \#
xanadu|Projects/subscription-manager|:master ✓ ❯ 

Additionally, the firstboot window in question has been renamed to "Subscription Registration".

Marking VERIFIED.
Comment 8 errata-xmlrpc 2013-01-07 22:49:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.