Bug 810377 - Circular build dependency in perl-SQL-Statement-1.33-4.fc18
Circular build dependency in perl-SQL-Statement-1.33-4.fc18
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-SQL-Statement (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 15:31 EDT by Paul Howarth
Modified: 2012-04-10 05:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 05:03:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2012-04-05 15:31:03 EDT
perl-SQL-Statement has a buildreq of perl(DBD::CSV) >= 0.30, which is used in the
test suite if available. However, DBD::CSV itself buildrequires and requires SQL::Statement, so this creates a circular build dependency, which will be a problem when we come to build everything for perl 5.16. Suggested fix is to not buildrequire DBD::CSV when bootstrapping:

diff --git a/perl-SQL-Statement.spec b/perl-SQL-Statement.spec
index a5a8c64..2c1930f 100644
--- a/perl-SQL-Statement.spec
+++ b/perl-SQL-Statement.spec
@@ -17,7 +17,10 @@ BuildRequires:  perl(Clone) >= 0.30
 BuildRequires:  perl(Params::Util) >= 1.00
 # for tests only:
 BuildRequires:  perl(DBD::AnyData) >= 0.110
+# DBD::CSV buildrequires SQL::Statement
+%if 0%{!?perl_bootstrap:1}
 BuildRequires:  perl(DBD::CSV) >= 0.30
+%endif
 BuildRequires:  perl(DBD::DBM) >= 0.06
 BuildRequires:  perl(DBD::File) >= 0.40
 BuildRequires:  perl(DBD::SQLite)
Comment 1 Marcela Mašláňová 2012-04-06 08:19:55 EDT
Thanks. The patch looks fine.
Comment 2 Paul Howarth 2012-04-06 13:52:16 EDT
Unfortunately I missed another cycle here. DBD::AnyData also requires SQL::Statement and so needs to be avoided when bootstrapping:

diff --git a/perl-SQL-Statement.spec b/perl-SQL-Statement.spec
index c2448b5..9c967a2 100644
--- a/perl-SQL-Statement.spec
+++ b/perl-SQL-Statement.spec
@@ -16,9 +16,9 @@ BuildRequires:  perl(ExtUtils::MakeMaker)
 BuildRequires:  perl(Clone) >= 0.30
 BuildRequires:  perl(Params::Util) >= 1.00
 # for tests only:
-BuildRequires:  perl(DBD::AnyData) >= 0.110
-# DBD::CSV buildrequires SQL::Statement
+# DBD::AnyData and DBD::CSV require SQL::Statement
 %if 0%{!?perl_bootstrap:1}
+BuildRequires:  perl(DBD::AnyData) >= 0.110
 BuildRequires:  perl(DBD::CSV) >= 0.30
 %endif
 BuildRequires:  perl(DBD::DBM) >= 0.06
Comment 3 Marcela Mašláňová 2012-04-10 05:03:57 EDT
According to file Changes was DBD::AnyData removed, because it didn't work well. I removed it from BR. Test passed even without it.

Note You need to log in before you can comment on or make changes to this bug.