Bug 810393 - e2fsck reports device busy but that device was unmounted successfully
e2fsck reports device busy but that device was unmounted successfully
Status: CLOSED DUPLICATE of bug 808795
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-05 16:34 EDT by George R. Goffe
Modified: 2012-04-12 16:00 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-12 16:00:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George R. Goffe 2012-04-05 16:34:28 EDT
Description of problem:

I put a disk in my system and turned it on and then mounted it's single partition and then decided to force e2fsck on it. I unmounted it first but e2fsck reports that it's busy. lsof shows jbd2 (kernel process?) doing something with the disk.

Version-Release number of selected component (if applicable):

e2fsprogs-1.41.14-2.fc15.x86_64
util-linux-2.20.1-2.2.fc16.x86_64

How reproducible:

unknown

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:

e2fsck -f /dev/sde1 complains that the device is busy

Expected results:

e2fsck to force fsck for this filesystem

Additional info:
Comment 1 Norman Smith 2012-04-11 16:25:21 EDT
See bug 808795.  It appears related.
Comment 2 Milan Broz 2012-04-12 06:47:59 EDT
And bug 809188 as well.

We found some very strange unmout path called in VFS, seems like it keep internally some reference.

I have system where it is easily reproduced, so I will try to work with Lukas to move it somewhere, it hits too many people already.
Comment 3 Milan Broz 2012-04-12 16:00:40 EDT

*** This bug has been marked as a duplicate of bug 808795 ***

Note You need to log in before you can comment on or make changes to this bug.