Bug 810431 - vncreflector segfaults when '-f' is specified
vncreflector segfaults when '-f' is specified
Status: CLOSED DUPLICATE of bug 569350
Product: Fedora
Classification: Fedora
Component: vnc-reflector (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Petr Pisar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 02:00 EDT by Josh Chia
Modified: 2012-04-06 04:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-06 04:13:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Chia 2012-04-06 02:00:49 EDT
Description of problem:

When running vncreflector with '-f 6' it segfaults.

Version-Release number of selected component (if applicable):


How reproducible:
Totally reproducible

Steps to Reproduce:
1. run $ vncreflector -f 6 -i reflector -a reflector.active -b 127.0.0.1 -p reflector.passwd reflector.info
  
Actual results:
VNC Reflector 1.2.4.  Copyright (C) 2001-2003 HorizonLive.com, Inc.

HorizonLive provides e-Learning and collaborative synchronous presentation
solutions in a totally Web-based environment.  For more information about
HorizonLive, please see our website at http://www.horizonlive.com/

06/04/12 01:56:08 + Starting VNC Reflector H=���s1�H��Τ
06/04/12 01:56:08   Our machine is little endian
06/04/12 01:56:08 : Looking for passwords in the file "reflector.passwd"
06/04/12 01:56:08   Got 2 password(s) from file, including empty ones
06/04/12 01:56:08 - Would bind listening sockets to address (null)
06/04/12 01:56:08 + Segmentation fault

Expected results:
No crash

Additional info:
I took a look at the source code on sourceforge. This project seems to be in an unfortunate state of non-maintenance, at least as far as I can tell from Googling it. However, somebody has made a patch to fix this. Basically, va_arg is being used wrongly. This is the patch and when I apply it on the source code I got from SF, it works:
http://sourceforge.net/tracker/?func=detail&aid=2984246&group_id=38605&atid=422840
Comment 1 Petr Pisar 2012-04-06 04:13:33 EDT

*** This bug has been marked as a duplicate of bug 569350 ***

Note You need to log in before you can comment on or make changes to this bug.