Bug 810439 - Should check the latest rhc-rest while installing or updating rhc client even if already having an old version.
Should check the latest rhc-rest while installing or updating rhc client even...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Fotios Lindiakos
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 03:24 EDT by Xiaoli Tian
Modified: 2015-05-14 21:50 EDT (History)
4 users (show)

See Also:
Fixed In Version: rhc-0.90.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-20 11:38:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoli Tian 2012-04-06 03:24:07 EDT
Description of problem:
If we already have rhc-rest installed (maybe an old version), if trying to install or update rhc client, it will only update rhc-client, but not trying to check if there's update for rhc-rest, which means we need to update rhc-rest manually.

Version-Release number of selected component (if applicable):
rhc-0.89.12-1.el6_2.noarch  

How reproducible:
Always

Steps to Reproduce:
1. Yum remove rhc (if you have installed)
2. Install an old version of rhc-rest: rpm -ivh rhc-rest-0.0.7-1.git.0.6ec063c.el6_2.noarch.rpm (you need to download the package firstly)

3. Yum install rhc
  
Actual results:
It will only update rhc, but not udpate rhc-rest even if there's an update for rhc-rest which is rhc-rest-0.0.8-1.el6_2.noarch.rpm.

Expected results:
rhc-rest should be updated as well if there's update version for it since some of our client bugs are fixed in rhc-rest.

Additional info:
Comment 1 Fotios Lindiakos 2012-04-10 10:55:57 EDT
Added explicit requires version to client.spec. Right now this needs to be manually updated every time rhc-rest is updated, but may be able to be automated.
Comment 2 Xiaoli Tian 2012-04-12 02:49:46 EDT
Move it to ON_QA since we get the build
Comment 3 Xiaoli Tian 2012-04-12 02:51:04 EDT
Verify it on rhc-0.90.5-1.el6_2.noarch
rhc-rest-0.0.11-1.el6_2.noarch, it will try to find the latest rhc while upgrading rhc
Comment 4 Mike McGrath 2012-04-12 22:57:09 EDT
We need to update the tooling so rhc always deps on whatever the latest version of rhc-rest is at built time.  Otherwise we'll never remember to keep these two in sync all the time.  (alternatively we could start bundling rhc-rest inside rhc)
Comment 5 Fotios Lindiakos 2012-04-20 11:38:58 EDT
This is no longer a problem since rhc-rest was incorporated into the rhc gem/rpm directly. Closing this bug.

Note You need to log in before you can comment on or make changes to this bug.