Bug 810457 - Connectivity check is not enabled in F17 builds
Connectivity check is not enabled in F17 builds
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 04:56 EDT by Sarantis Paskalis
Modified: 2013-06-30 21:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.8.2-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-30 21:47:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sarantis Paskalis 2012-04-06 04:56:22 EDT
Description of problem:
Connectivity checking is not enabled in F17 and rawhide builds.

Version-Release number of selected component (if applicable):
NetworkManager-0.9.4.0-1.git20120328.fc17.i686

The specfile needs 

BuildRequires: libsoup-devel

to enable the connectivity checking support. Requires: libsoup is not strictly needed, since rpm takes care of the libsoup.so dependency.

I did a scratch build that takes care of that and it seems to work fine.
Comment 1 Fabrice Bellet 2013-01-07 09:22:30 EST
I confirm: BR libsoup-devel >= 2.26 is needed in the spec file (NetworkManager-0.9.7.0-11.git20121004.fc18)
Comment 2 Dan Williams 2013-01-07 11:26:54 EST
We probably can't do this until libsoup gets split up into a libsoup and libsoup-gnome package.  Since they're all in the same package right now, just installing 'libsoup' brings in gnome-keyring and sqlite which shouldn't really be hard requirements of NM itself.
Comment 3 Fedora Update System 2013-06-27 07:27:04 EDT
NetworkManager-0.9.8.2-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.8.2-4.fc19
Comment 4 Fedora Update System 2013-06-27 11:46:41 EDT
Package NetworkManager-0.9.8.2-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.8.2-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11826/NetworkManager-0.9.8.2-4.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-06-30 21:47:23 EDT
NetworkManager-0.9.8.2-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.