Bug 810472 - push build often got failed when trying jenkins build for the first time
push build often got failed when trying jenkins build for the first time
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
1.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Bill DeCoste
libra bugs
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 06:13 EDT by Meng Bo
Modified: 2012-04-27 16:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-27 16:47:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
jenkins.log (25.08 KB, application/octet-stream)
2012-04-23 00:15 EDT, Johnny Liu
no flags Details

  None (edit)
Description Meng Bo 2012-04-06 06:13:28 EDT
Description of problem:
create jbossas app and embedded jenkins client to it. modify the node profile to medium.make some changes and push the build.

Version-Release number of selected component (if applicable):
cartridge-jenkins-1.4-0.89.3-1.git.0.7a5fab1.el6_2.noarch
cartridge-jenkins-client-1.4-0.23.4-1.git.0.3eb3a5e.el6_2.noarch

How reproducible:
always

Steps to Reproduce:
1.create jbossas app
2.create jenkins server
3.embed jenkins client to jbossas app
4.modify the node profile to medium
5.make some change and push the build
  
Actual results:
push build got failed.

remote: Waiting for build to schedule................................................
remote: **BUILD FAILED/CANCELLED**
remote: Please see the Jenkins log for more details via rhc-tail-files
remote: !!!!!!!!
remote: Deployment Halted!
remote: If the build failed before the deploy step, your previous
remote: build is still running.  Otherwise, your application may be
remote: partially deployed or inaccessible.
remote: Fix the build and try again.
remote: !!!!!!!!



Expected results:
build should be pushed without any problem.

Additional info:
jenkins server log:
http://pastebin.test.redhat.com/84426

There is no such problem for other types of apps.
Comment 1 Xiaoli Tian 2012-04-06 10:10:24 EDT
This bug does not always happen, it will often happen when you try to build with jenkins the first time, but it could be successful if you git push again to trigger the jenkins build,leave this bug open to see if there is any fix for this.

The first time build error log is like following :

com.openshift.express.client.OpenShiftEndpointException: Could not configure application "jbsbldr" at "https://localhost/broker/cartridge"
        at com.openshift.express.client.OpenShiftService.sendRequest(OpenShiftService.java:528)
        at com.openshift.express.client.OpenShiftService.requestApplicationAction(OpenShiftService.java:435)
        at com.openshift.express.client.OpenShiftService.createApplication(OpenShiftService.java:290)
        at hudson.plugins.openshift.OpenShiftSlave.createApp(OpenShiftSlave.java:235)
        at hudson.plugins.openshift.OpenShiftSlave.provision(OpenShiftSlave.java:204)
        at hudson.plugins.openshift.OpenShiftCloud$2.call(OpenShiftCloud.java:459)
        at hudson.plugins.openshift.OpenShiftCloud$2.call(OpenShiftCloud.java:451)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
        at java.util.concurrent.FutureTask.run(FutureTask.java:166)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:679)
Caused by: com.openshift.express.internal.client.httpclient.BadRequestException: {"api_c":["placeholder"],"data":"","debug":"","broker_c":[
"namespace","rhlogin","ssh","app_uuid","debug","alter","cartridge","cart_type","action","app_name","api"],"api":"1.1.3","result":"Failed: E
ither application limit has already reached or domain doesn't exist for 'xtian+t82@redhat.com'","messages":"","exit_code":1}
Comment 2 Bill DeCoste 2012-04-09 13:12:19 EDT
What AMI and environment are you seeing this? There is not a medium builder available for JBoss in devenvs, so it will always fail.
Comment 3 Xiaoli Tian 2012-04-09 21:11:52 EDT
Hi, Bill

It should be devenv_1696 or devenv_1697, we have already changed the node profile to medium , so it should not be caused short of medium builder.

Thanks
Comment 4 Johnny Liu 2012-04-23 00:14:02 EDT
Re-test this bug on devenv_1735, still failed when do jenkins build for the first time, but some symptom has changed.
About the error - "Either application limit has already reached or domain doesn't exist" has been fixed in BZ#811192.

The following is my steps to reflect current status:
1. Launch a devenv instance.
2. Create app with jenkins embedded.
3. Do git push to trigger jenkins build.
***The first jenkins build failed***
4. After jenkins build failed, do git push again.
***This jenkins build succeed***


Check jenkins log, found the first failure is caused by the following error:
<--snip-->
Caused by: com.openshift.express.internal.client.httpclient.InternalServerErrorException: {"api":"1.1.3","api_c":["placeholder"],"messages":"\n!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!\nWARNING: The 'bldr' suffix is used by the CI system (Jenkins) for its slave \nbuilders.  If you create an app of this name you can't also create an app \ncalled 'phptest' and build that app in Jenkins without conflicts.\n!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!\n","data":"","exit_code":1,"result":"Error communicating with DNS system.  If the problem persists please contact Red Hat support.","debug":"","broker_c":["namespace","rhlogin","ssh","app_uuid","debug","alter","cartridge","cart_type","action","app_name","api"]}
<--snip-->

Please check attachment (jenkins.log) for more details info
Comment 5 Johnny Liu 2012-04-23 00:15:07 EDT
Created attachment 579408 [details]
jenkins.log
Comment 6 Bill DeCoste 2012-04-24 21:09:10 EDT
Looks like there was already an application of the name phptestblder - can you confirm there isn't a conflict with the existing applications? My concern is that a builder is not being cleaned up properly. I just created a new jenkins-plugin-openshift build (0.5.18) to revolve another bug so you should test with that version.
Comment 7 Johnny Liu 2012-04-24 22:32:35 EDT
Now the version of jenkins-plugin-openshift in the latest instance (devenv_1741) is jenkins-plugin-openshift-0.5.17, after get the new jenkins-plugin-openshift build (0.5.18), I will test it again.
Comment 8 Johnny Liu 2012-04-25 23:02:06 EDT
Re-test this issue on devenv-stage_176, it works fine now. So move it to "ON_QA".
Comment 9 Johnny Liu 2012-04-25 23:02:43 EDT
According to comment 8, verified this bug.

Note You need to log in before you can comment on or make changes to this bug.