This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 810483 - Burning DVD media using growisofs sometimes fails
Burning DVD media using growisofs sometimes fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 07:03 EDT by Honza Horak
Modified: 2012-05-03 18:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: dvd+rw-tools-7.1-9.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-02 16:50:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed patch - align blocks count to multiple of 16 (589 bytes, patch)
2012-04-06 08:25 EDT, Honza Horak
no flags Details | Diff
proposed patch - allow the written chunk to be smaller than multiple of 16 blocks (593 bytes, patch)
2012-04-20 09:24 EDT, Honza Horak
no flags Details | Diff

  None (edit)
Description Honza Horak 2012-04-06 07:03:00 EDT
Description of problem:

Burning DVD media using growisofs sometimes fails, burning BD-RE media, however, succeeds.

The following error message while writing on DVD-RW media

/dev/sr0: "Current Write Speed" is 4.1x1352KBps.
:-[ WRITE@LBA=350h failed with SK=0h/ASC=00h/ACQ=03h]: Input/output error :-(
write failed: Input/output error
/dev/sr0: flushing cache


Version-Release number of selected component (if applicable):

dvd+rw-tools-7.1-5.fc14.x86_64

How reproducible:

Only with iso images that has different size than a multiple of 32k

Steps to Reproduce:
1. Create an iso image, that has NOT size of multiple of 32k
2. growisofs -Z /dev/sr0=/path/to/your.iso

Actual results:

The following error is displayed during burn:
:-[ WRITE@LBA=350h failed with SK=0h/ASC=00h/ACQ=03h]: Input/output error :-(
write failed: Input/output error

However, the medium seems to be burned correctly.

Expected results:

No error.

Additional info:
After several kernel versions and more optical drives have been tested it seems there's no difference. Thus, it seems to be a bug in growisofs.
Comment 1 Honza Horak 2012-04-06 08:25:36 EDT
Created attachment 575723 [details]
proposed patch - align blocks count to multiple of 16

When burning DVD media in DAO mode, reserved blocks count wasn't align to
multiple of 16 (which means space of 32kB). However, only 32kB blocks were
being written to the media, so I suppose the error was triggered by the drive
complaining that we were writing the last block outside the reserved area
boundaries.
Comment 2 Fedora Update System 2012-04-06 09:09:36 EDT
dvd+rw-tools-7.1-8.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dvd+rw-tools-7.1-8.fc17
Comment 3 Fedora Update System 2012-04-06 09:12:53 EDT
dvd+rw-tools-7.1-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dvd+rw-tools-7.1-8.fc16
Comment 4 Fedora Update System 2012-04-06 09:13:52 EDT
dvd+rw-tools-7.1-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/dvd+rw-tools-7.1-8.fc15
Comment 5 Fedora Update System 2012-04-06 19:23:11 EDT
Package dvd+rw-tools-7.1-8.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dvd+rw-tools-7.1-8.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5451/dvd+rw-tools-7.1-8.fc17
then log in and leave karma (feedback).
Comment 6 Honza Horak 2012-04-20 09:24:21 EDT
Created attachment 579002 [details]
proposed patch - allow the written chunk to be smaller than multiple of 16 blocks

I've discussed this bug with Thomas, author of libburn, since dvd+rw-tools upstream is not very active for some time.

The original patch would work, but DAO session does not need to be aligned to 16 blocks necessarily according to standard. What's more, for the sake of ISO image verification it is desirable to have a DVD session of exactly the image size.

Current version doesn't comply with that, because the buffer size passed into WRITE command is aligned to 16 blocks every-time. This patch sets the buffer size to exactly the number of blocks to be written, which fixes the reported bug.
Comment 8 Fedora Update System 2012-05-02 16:50:38 EDT
dvd+rw-tools-7.1-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-05-03 18:51:02 EDT
dvd+rw-tools-7.1-9.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-05-03 18:52:35 EDT
dvd+rw-tools-7.1-9.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.