Bug 810513 - update repo= documentation about partial installation trees
update repo= documentation about partial installation trees
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 09:47 EDT by Kamil Páral
Modified: 2012-05-07 06:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-07 06:38:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-04-06 09:47:35 EDT
Description of problem:
Since F17 anaconda split its root image from initrd, we have a new use case - we want to boot the installer from PXE, but we want to install the packages from online repositories, without the requirement to have it mirrored locally. [1]

Currently repo= documentation says it's not possible:

"This option must point to a valid yum repository."
http://fedoraproject.org/wiki/Anaconda/Options

However, Will Woods confirmed this use case is to be supported. Please update repo= documentation to say that the remote location doesn't have to contain package repository, just the required images (that is currently broken by bug 790348).

> adamw	 so you can pass repo= for a location which does not in fact contain packages, but does contain the installer	16:10
> adamw	 and anaconda should deal correctly with that?	16:10
> wwoods	 as long as there's a .treeinfo file that points to the [stage2] mainimage it should work

Or, wwoods proposed to create an alternative solution if repo= couldn't be adjusted:

> kparal	 I'm 100% sure that missing yum repository in the repo= location aborts installation. I reported bug about it. I can dig it up	16:14
> wwoods	 kparal: if that's the case I'll make sure we have some alternate method to boot with just images


Please either adjust the documentation (and fix the linked bug) (preferred), or create a new solution for that use case instead.

[1] https://fedoraproject.org/wiki/QA/Meetings/20120326#t15:50:50

Note You need to log in before you can comment on or make changes to this bug.