Bug 810540 - [gui] logging out should clear the ResourceType cache
[gui] logging out should clear the ResourceType cache
Status: CLOSED DEFERRED
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.3
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Mike Foley
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 11:17 EDT by Ian Springer
Modified: 2013-08-05 20:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-26 16:17:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2012-04-06 11:17:39 EDT
Currently if existing ResourceTypes are updated as part of a plugin update, the updates do not get picked up by the GUI, because the GUI's cache contains the old types. This is fine, except the only way for the user to get the types updated in the GUI except is to do a hard browser refresh. This is not very intuitive and causes the user to have to wait several seconds for the page to load. Logging out should also clear the type cache. Then we can say in the documentation, "if you update any Agent plugins, to pick up the changes in the GUI, log out and then log back in.
Comment 1 Charles Crouch 2012-04-09 10:28:34 EDT
Not sure I agree that the cache should be cleared on log out, since changes to 
ResourceTypes should in general be pretty rare in production deployments, e.g. 
upgrading to new JON versions, patches, new customer developed plugins. It 
seems a waste to have people download that extra data (presumably is a lot?) on 
every login. I agree its not great that it requires a hard refresh right now, 
this is less good because not every user is going to know that they need to do 
that.

I would say we need a way to invalidate the ResourceType cache in the browser 
when it needs to be updated, rather than a blanket cache eviction policy.
Comment 2 Jay Shaughnessy 2013-02-26 16:17:11 EST
Closing this.  If and when we get server2gui notification we'll take care of this as part of that work.

Note You need to log in before you can comment on or make changes to this bug.