Bug 810583 - disconnect() method of spice-xpi does not kill client
Summary: disconnect() method of spice-xpi does not kill client
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-xpi
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 6.4
Assignee: Peter Hatina
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On: 815674
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-06 21:08 UTC by David Jaša
Modified: 2016-06-01 01:31 UTC (History)
6 users (show)

Fixed In Version: spice-xpi-2.7-21.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:57:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0459 0 normal SHIPPED_LIVE spice-xpi bug fix update 2013-02-20 21:07:29 UTC

Description David Jaša 2012-04-06 21:08:26 UTC
Description of problem:
disconnect() method of spice-xpi does not kill client - it continues to run.

Version-Release number of selected component (if applicable):
spice-xpi-2.7-16.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. from test page, connect client to spice server
2. switch to the web browser again
3. hit 'Disconnect' button
  
Actual results:
client keeps running

Expected results:
client is closed

Additional info:

Comment 1 Peter Hatina 2012-04-25 13:33:00 UTC
In current state, we are not able to solve this in a reasonable way. Now we have alternatives, so /usr/libexec/spice-xpi-client points to 2 shell scripts, which run either spicec or remote-viewer. The problem is, that if I signal (by SIGTERM) spice-xpi-client, the client does not die -- caused by the structure of the script(s). The best solution could be: to signal a process group, where the parent is the mentioned spice-xpi-client.

Rhel 6.3 in current state suffers from a bug, where is is not able to signal a process group. I already filed that bug.

Comment 2 David Blechter 2012-04-25 13:43:02 UTC
Moving to 6.4 for now:
First, it depend on https://bugzilla.redhat.com/show_activity.cgi?id=815674;
and second, spice devel is focusing on virt-vierwer as the spicec replacement.

Comment 5 Peter Hatina 2012-08-01 08:27:20 UTC
Fixed.

Comment 9 errata-xmlrpc 2013-02-21 10:57:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0459.html


Note You need to log in before you can comment on or make changes to this bug.