Bug 810586 - Erlang should not pull in xorg X11
Erlang should not pull in xorg X11
Status: CLOSED DUPLICATE of bug 784693
Product: Fedora EPEL
Classification: Fedora
Component: erlang (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 17:53 EDT by Volker Fröhlich
Modified: 2012-04-08 12:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-08 12:43:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Volker Fröhlich 2012-04-06 17:53:27 EDT
Description of problem:

Installing ejabberd forces you to install xorg X11. This can be very unpleasant on a server.


Cause:

Erlang explicitly requires the erlang-wx sub-package, which causes this behaviour.
Comment 1 Volker Fröhlich 2012-04-08 12:02:59 EDT
#784693 is pretty similar.
Comment 2 Peter Lemenkov 2012-04-08 12:43:40 EDT
Hello.

(In reply to comment #0)
> Description of problem:
> 
> Installing ejabberd forces you to install xorg X11. This can be very unpleasant
> on a server.
> 
> 
> Cause:
> 
> Erlang explicitly requires the erlang-wx sub-package, which causes this
> behaviour.

(In reply to comment #1)
> #784693 is pretty similar.

Yes, it's the same issue. I'll try to cut off dependency chain in the nearest future but right now I'm busy with upgrading to R15B01. It doesn't pulls the entire X.0rg after all - just a bunch of libraries.

Stay tuned!

*** This bug has been marked as a duplicate of bug 784693 ***

Note You need to log in before you can comment on or make changes to this bug.