Bug 810614 - GdkEventButton contains wrong buttons in modifier mask for button releases
GdkEventButton contains wrong buttons in modifier mask for button releases
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-07 04:36 EDT by Hans de Goede
Modified: 2012-04-22 00:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: gtk3-3.4.1-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-22 00:21:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2012-04-07 04:36:20 EDT
This is a copy of a bug I filed upstream, which is fixed now:
https://bugzilla.gnome.org/show_bug.cgi?id=673458

The intend of this Fedora copy of the bug is to track getting the fix into Fedora. Getting this fix into Fedora is important, because the bug causes spurious mouse clicks when viewing virtual-machines with
spice-gtk based clients, and Spice is the default display protocols for virtual machines in Fedora 16 and Fedora 17.

I don't know if a gtk3 bugfix release will happen soon upstream, if not I would like to see the patch fixing
this added to the Fedora gtk3 package. I can add the patch and rebuild gtk3 myself, if this is ok with
you?

Text from original / upstream bug below:

While debugging an issue with spice-gtk I eventually found out that gdk3 is
reporting a wrong modifier mask for button release events for buttons > 1. The
problem is that the modifier mask always contains the GDK_BUTTON1_MASK for
release events even if button1 was not pressed at the time of the release.

I've seen this with a fully up2date Fedora-17 on 2 different machines.

Attached it a simply reproducer, running this and then pressing buttons 1 - 3
in succession (releasing each one before pressing the next) gives the following
output:
press,   button 1, mask 0x0000
release, button 1, mask 0x0100
press,   button 2, mask 0x0000
release, button 2, mask 0x0300
press,   button 3, mask 0x0000
release, button 3, mask 0x0500
Comment 1 Fedora Update System 2012-04-13 22:47:15 EDT
gtk3-3.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/gtk3-3.4.1-1.fc17
Comment 2 Fedora Update System 2012-04-14 13:49:30 EDT
Package gtk3-3.4.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gtk3-3.4.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5899/gtk3-3.4.1-1.fc17
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2012-04-22 00:21:05 EDT
gtk3-3.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.