Bug 810615 - Cannot link my phone to my computer with gnome-shell 3.4.0
Cannot link my phone to my computer with gnome-shell 3.4.0
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2012-04-07 04:46 EDT by Michael Scherer
Modified: 2012-04-19 13:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-04-19 13:50:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 674414 None None None Never

  None (edit)
Description Michael Scherer 2012-04-07 04:46:53 EDT
Description of problem:

I cannot add new bluetooth device, it fail without explicit error message after confirming the code. In .xsession-errors, I see this 

Avertissement du gestionnaire de fenêtres : Log level 8: g_variant_lookup_value: assertion `g_variant_is_of_type (dictionary, G_VARIANT_TYPE ("a{s*}")) || g_variant_is_of_type (dictionary, G_VARIANT_TYPE ("a{o*}"))' failed
    JS ERROR: !!!   Exception was: TypeError: args[i++] is null
    JS ERROR: !!!     lineNumber = '41'
    JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/misc/format.js"'
    JS ERROR: !!!     stack = '"("%s","","","s",45,"Confirmation de la demande de liaison pour \xAB\xA0%s\xA0\xBB")@/usr/share/gnome-shell/js/misc/format.js:41
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/2540/hci0/dev_2C_45_01_47_88_6A",null,null,476044)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:408
wrapper([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/2540/hci0/dev_2C_45_01_47_88_6A",null,null,476044)@/usr/share/gjs-1.0/lang.js:204
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/2540/hci0/dev_2C_45_01_47_88_6A",null,null,476044)@/usr/share/gjs-1.0/lang.js:145
([object Object],[object _private_GnomeBluetoothApplet_Applet],"/org/bluez/2540/hci0/dev_2C_45_01_47_88_6A",null,null,476044)@/usr/share/gjs-1.0/lang.js:239
([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/2540/hci0/dev_2C_45_01_47_88_6A",null,null,476044)@/usr/share/gnome-shell/js/ui/status/bluetooth.js:323
wrapper([object _private_GnomeBluetoothApplet_Applet],"/org/bluez/2540/hci0/dev_2C_45_01_47_88_6A",null,null,476044)@/usr/share/gjs-1.0/lang.js:204
    JS ERROR: !!!     message = '"args[i++] is null"'

Version-Release number of selected component (if applicable):
$ rpm -q gnome-shell

How reproducible:
each time

Steps to Reproduce:
1. take a phone, ( in my case, a galaxy s II )
2. enable bluetooth
3. try to link the phone with the computer, using gnome bluetooth wizard
Actual results:
after showing the code to confirm and confirming on both the phone and the computer, it say "cannot appair" 

Expected results:

that appairing work fine
Comment 1 Owen Taylor 2012-04-09 11:01:09 EDT
Bastien: can you look at this? It appears that gnome-bluetooth/applet/bluetooth-applet.c:confirm_request() is emitting the signal with a null name - we could default name to <unknown> or something in gnome-shell, but probably it's better to handle things in gnome-bluetooth?
Comment 2 Owen Taylor 2012-04-10 12:45:32 EDT
What are the installed versions of gnome-bluetooth and bluez on your system?
Does this depend on locale - if you switch to English and re-login does it work?
Comment 3 Michael Scherer 2012-04-10 14:37:58 EDT
So for the version :
 $ rpm -q bluez gnome-shell

Let me just now relogin to test
Comment 4 Michael Scherer 2012-04-10 14:47:32 EDT
Same problem with english locale.
Comment 5 Owen Taylor 2012-04-11 12:05:31 EDT
Thanks - was actually asking about the version of gnome-bluetooth not gnome-shell.
Comment 6 Michael Scherer 2012-04-13 07:33:07 EDT
Oh, sorry, misunderstood.

$ rpm -q gnome-bluetooth

As a side note, I tried on a second computer, and there is it doesn't produce the same error message in .xsession-errors, but this spin forever too, and seems to add it fine, except it take several minutes to finish.

The behavior between the 2 computer is also different. On the first one, my phone say "can you confirm this is the code", and on the 2nd one, it ask me to enter the code. It work fine on 

First is a lenovo T410, second is a macbook from 2007. Maybe that's linked to different type of bluetooth chipset ?
Comment 7 Owen Taylor 2012-04-19 13:50:18 EDT
Moved upstream to https://bugzilla.gnome.org/show_bug.cgi?id=674414

Note You need to log in before you can comment on or make changes to this bug.