Bug 810659 - iso image in boot partition cannot boot
iso image in boot partition cannot boot
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
16
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-07 16:06 EDT by Chris Miller
Modified: 2013-02-13 09:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-13 09:12:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Miller 2012-04-07 16:06:27 EDT
Hi Folks,

Years ago I wanted to install Fedora which was distributed as a DVD but I had no DVD burner... So, I developed the technique to copy the iso to my boot partition, copy the selected vmlinuz and initrd.img from the distro isolinux directory, and run vmlinuz with the associated anaconda initrd.img, and Voila! Fedora comes to life. These days, optical readers are not necessarily going to be present in the lightweight net books and such, but USB is always present, so there is still a need to do this.

The syslinux stanza looks like this:

LABEL Install
        MENU LABEL ^Install / Upg Fedora-16
        KERNEL /Fedora/16/isolinux/vmlinuz
        INITRD /Fedora/16/isolinux/initrd.img
        APPEND lang=en_US keymap=us

Today, I tried a similar technique to boot a Live image from my boot partition of my traveling USB disk.  I suffered obstruction from dracut.  







Description of problem:
dracut won't boot an iso image from the boot partition of a disk.

How reproducible:
100%







Steps to Reproduce:
I tried two techniques:

First Technique - vmlinuz0:
  LABEL Fedora-16-Live-LXDE-32
      MENU LABEL Fedora 16 Live (LXDE-32)
      KERNEL /Fedora/16/Fedora-16-i686-Live-LXDE/vmlinuz0
      INITRD /Fedora/16/Fedora-16-i686-Live-LXDE/initrd0.img
      APPEND rdshell

Note: the iso image is located in the same directory as vmlinuz0 and initrd0.img.

This technique fails before any graphical activity:
[    2.340273] generic-usb 0003:0627:0001.001: inout,hidraw0:USB HID v0.01 pointer [QEMU 0.11.0 QEMU USB Tablet] on usb-0000:00:01.2-2/input0
[    2.426719] dracut: dracut-013-18.fc16
[    2.544125] dracut Refusing to continue

[    2.554336] dracut Warning: dracut; FATAL: No or empty root= argument



Second Technique - memdisk:
  LABEL Fedora-16-Live-LXDE-32-memdisk
      MENU LABEL Fedora 16 Live (LXDE-32)
      KERNEL /syslinux/memdisk
      INITRD /Fedora/16/Fedora-16-i686-Live-LXDE.iso
      APPEND iso raw

This technique fails after the graphical load screen starts and the progress bars are midway and the "Fedora 16" message in the lower right corner has displayed:

dracut Warning: No root device "live:/dev/disk/by-label/Fedora-16-i686-Live-LXDE.iso" found

the second technique drops me into a debug shell, but I don't know what to do or what to find, so I await your instructions.



  
Actual results:
See above in Steps to Reproduce





Expected results:
Live media should boot and run as though I had the optical CD in a CDROM.



Additional info:
Comment 1 Fedora End Of Life 2013-01-16 08:25:02 EST
This message is a reminder that Fedora 16 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 16. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '16'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 16's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 16 is end of life. If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora, you are encouraged to click on 
"Clone This Bug" and open it against that version of Fedora.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora End Of Life 2013-02-13 09:13:01 EST
Fedora 16 changed to end-of-life (EOL) status on 2013-02-12. Fedora 16 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.