Bug 810661 - SELinux is preventing /usr/libexec/kde4/kcmdatetimehelper from 'create' accesses on the arquivo Trolltech.conf.T13298.
SELinux is preventing /usr/libexec/kde4/kcmdatetimehelper from 'create' acces...
Status: CLOSED DUPLICATE of bug 694385
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:f836ddee3b61ff41fd9ae35cc1a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-07 16:30 EDT by Lucelio Gomes de Freitas
Modified: 2012-04-09 17:22 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-09 17:22:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucelio Gomes de Freitas 2012-04-07 16:30:41 EDT
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.3.0-8.fc16.x86_64
reason:         SELinux is preventing /usr/libexec/kde4/kcmdatetimehelper from 'create' accesses on the arquivo Trolltech.conf.T13298.
time:           Sáb 07 Abr 2012 17:28:40 BRT

description:
:SELinux is preventing /usr/libexec/kde4/kcmdatetimehelper from 'create' accesses on the arquivo Trolltech.conf.T13298.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that kcmdatetimehelper should be allowed create access on the Trolltech.conf.T13298 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep kcmdatetimehelp /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:gnomeclock_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:root_t:s0
:Target Objects                Trolltech.conf.T13298 [ file ]
:Source                        kcmdatetimehelp
:Source Path                   /usr/libexec/kde4/kcmdatetimehelper
:Port                          <Desconhecido>
:Host                          (removed)
:Source RPM Packages           kde-workspace-4.8.1-6.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-80.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.0-8.fc16.x86_64 #1 SMP Thu
:                              Mar 29 18:37:19 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Sáb 07 Abr 2012 17:29:08 BRT
:Last Seen                     Sáb 07 Abr 2012 17:29:08 BRT
:Local ID                      b9bc7f41-1892-4571-a3b9-c75b89a89e1c
:
:Raw Audit Messages
:type=AVC msg=audit(1333830548.83:150): avc:  denied  { create } for  pid=13298 comm="kcmdatetimehelp" name="Trolltech.conf.T13298" scontext=system_u:system_r:gnomeclock_t:s0-s0:c0.c1023 tcontext=system_u:object_r:root_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1333830548.83:150): arch=x86_64 syscall=open success=no exit=EACCES a0=25f92b8 a1=800c2 a2=180 a3=0 items=0 ppid=1 pid=13298 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=kcmdatetimehelp exe=/usr/libexec/kde4/kcmdatetimehelper subj=system_u:system_r:gnomeclock_t:s0-s0:c0.c1023 key=(null)
:
:Hash: kcmdatetimehelp,gnomeclock_t,root_t,file,create
:
:audit2allow
:
:#============= gnomeclock_t ==============
:allow gnomeclock_t root_t:file create;
:
:audit2allow -R
:
:#============= gnomeclock_t ==============
:allow gnomeclock_t root_t:file create;
:
Comment 1 Daniel Walsh 2012-04-09 15:40:28 EDT
This looks kde tools creating content in /
Comment 2 Kevin Kofler 2012-04-09 17:22:58 EDT

*** This bug has been marked as a duplicate of bug 694385 ***

Note You need to log in before you can comment on or make changes to this bug.