Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 810694 - viostor fails with DRIVER_IRQL_NOT_LESS_OR_EQUAL BOSD under heavy random write load
Summary: viostor fails with DRIVER_IRQL_NOT_LESS_OR_EQUAL BOSD under heavy random writ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win
Version: 6.3
Hardware: Unspecified
OS: Windows
unspecified
medium
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-04-08 11:12 UTC by Vadim Rozenfeld
Modified: 2017-12-14 07:31 UTC (History)
9 users (show)

Fixed In Version: build 26
Doc Type: Bug Fix
Doc Text:
This bug was reported upstream by several different people. Cause: it was a race condition in viostor driver due to incorrect flush requests handling. Consequence: Under heavy load, usually (but not always) when using cache=writheback option, flush handler was executed asynchronously without proper synchronisation with the rest of request processing logic. Fix: Synchronize execution of the flush request handler with ISR. Result: Fixed for all OSes including WinXp
Clone Of:
: 825986 (view as bug list)
Environment:
Last Closed: 2012-06-20 11:58:51 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0751 0 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2012-06-19 19:31:22 UTC

Description Vadim Rozenfeld 2012-04-08 11:12:12 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Run qemu with the following command line qemu-kvm -m MEMORY -smp SMP -cpu host -nodefaults -vga cirrus -vnc :1  -drive if=none,id=block.0,format=raw, cache=writeback,file=drive.img -device virtio-blk-pci,bootindex=1,
drive=block.0 -monitor stdio
2.stressed the disk by running Crystal Disk mark (a free IO measuring tool). 
3.When it got to the 4 KB random write tests - it would consistently blue screen.

  
Actual results:


Expected results:


Additional info:

Comment 1 Vadim Rozenfeld 2012-04-08 11:15:26 UTC
this bug was reported upstream :
https://github.com/YanVugenfirer/kvm-guest-drivers-windows/issues/2#issuecomment-5009116
http://lists.gnu.org/archive/html/qemu-devel/2012-03/msg04550.html

However it's easily reproducible on rhel6.3 as well

Comment 6 Mike Cao 2012-04-10 06:14:39 UTC
Reproduced this issue on virtio-win-prewhql-22
Verified this issue on virtio-win-prewhql-25

Steps:
1.start guest w/ cache=writeback
2.in the guest ,running Crystal Disk mark .choose "9  2000MB  C:\ “

Actual Results
On virtio-win-prewhql-22 ,guest BSOD ocurrs
On virtio-win-prewhql-25 ,gust works fine

Based on above ,this issue has been fixed ald .

Comment 9 Vadim Rozenfeld 2012-05-03 08:57:15 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
This bug was reported upstream by several different people.

Cause: it was a race condition in viostor driver due to incorrect flush requests handling.
Consequence: Under heavy load, usually (but not always) when using cache=writheback option, flush handler was executed asynchronously without proper synchronisation with the rest of request processing logic.
Fix: Synchronize execution of the flush request handler with ISR.
Result: Fixed for all OSes including WinXp

Comment 10 Thomas Cameron 2012-06-04 06:06:16 UTC
I could not find the build 25 package, so I am using build 26. Is that OK?

Comment 12 errata-xmlrpc 2012-06-20 11:58:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0751.html


Note You need to log in before you can comment on or make changes to this bug.