Bug 810721 - Circular build dependencies: perl-Test-WWW-Mechanize-Catalyst <-> perl-Catalyst-Plugin-Session-State-Cookie
Circular build dependencies: perl-Test-WWW-Mechanize-Catalyst <-> perl-Cataly...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: perl-Catalyst-Plugin-Session-State-Cookie (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Iain Arnell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-08 13:04 EDT by Paul Howarth
Modified: 2012-04-18 19:09 EDT (History)
4 users (show)

See Also:
Fixed In Version: perl-Test-WWW-Mechanize-Catalyst-0.57-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 19:09:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Howarth 2012-04-08 13:04:42 EDT
These two packages buildrequire each other. They're both optional test dependencies so it's a toss-up as to which one to break the cycle in. I tested both in F-17 as the packages require mod_perl, which is currently uninstallable in Rawhide. The perl-Catalyst-Plugin-Session-State-Cookie test suite skips a bit more gracefully so I'd tweak that one personally:

diff --git a/perl-Test-WWW-Mechanize-Catalyst.spec b/perl-Test-WWW-Mechanize-Catalyst.spec
index 5bd8df9..6aa12aa 100644
--- a/perl-Test-WWW-Mechanize-Catalyst.spec
+++ b/perl-Test-WWW-Mechanize-Catalyst.spec
@@ -10,7 +10,11 @@ Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $versi
 BuildArch:      noarch
 
 BuildRequires:  perl(Catalyst) >= 5.00
+# Catalyst::Plugin::Session::State::Cookie and Test::WWW::Mechanize::Catalyst
+# use each other in their test suites
+%if 0%{!?perl_bootstrap:1}
 BuildRequires:  perl(Catalyst::Plugin::Session::State::Cookie)
+%endif
 BuildRequires:  perl(Catalyst::Plugin::Session::Store::Dummy)
 BuildRequires:  perl(ExtUtils::MakeMaker) >= 6.42
 BuildRequires:  perl(LWP) >= 5.816


OR


diff --git a/perl-Catalyst-Plugin-Session-State-Cookie.spec b/perl-Catalyst-Plugin-Session-State-Cookie.spec
index 5ee95f4..9b0b929 100644
--- a/perl-Catalyst-Plugin-Session-State-Cookie.spec
+++ b/perl-Catalyst-Plugin-Session-State-Cookie.spec
@@ -20,7 +20,11 @@ BuildRequires:  perl(namespace::autoclean)
 BuildRequires:  perl(Test::MockObject) >= 1.01
 BuildRequires:  perl(Test::More)
 BuildRequires:  perl(Test::Pod)
+# Test::WWW::Mechanize::Catalyst and Catalyst::Plugin::Session::State::Cookie
+# use each other in their test suites
+%if 0%{!?perl_bootstrap:1}
 BuildRequires:  perl(Test::WWW::Mechanize::Catalyst)
+%endif
 
 Requires:       perl(Catalyst) >= 5.80005
 Requires:       perl(Catalyst::Plugin::Session) >= 0.27
Comment 1 Fedora Update System 2012-04-11 07:33:53 EDT
perl-Test-WWW-Mechanize-Catalyst-0.57-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/perl-Test-WWW-Mechanize-Catalyst-0.57-1.fc17
Comment 2 Iain Arnell 2012-04-11 07:35:22 EDT
Patch applied to Test-WWW-Mechanize-Catalyst because it was already due for an update to latest upstream version. Committed to rawhide and f17; built only for f17 since mod_perl is still broken.
Comment 3 Fedora Update System 2012-04-11 21:10:53 EDT
Package perl-Test-WWW-Mechanize-Catalyst-0.57-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-Test-WWW-Mechanize-Catalyst-0.57-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5725/perl-Test-WWW-Mechanize-Catalyst-0.57-1.fc17
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2012-04-18 19:09:06 EDT
perl-Test-WWW-Mechanize-Catalyst-0.57-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.