This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 810788 - duplicated entries in "blacklist" section for device-mapper-multipath-0.4.9-53
duplicated entries in "blacklist" section for device-mapper-multipath-0.4.9-53
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
6.3
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Ben Marzinski
Gris Ge
: Regression
Depends On:
Blocks: 840683
  Show dependency treegraph
 
Reported: 2012-04-09 03:18 EDT by Gris Ge
Modified: 2013-02-21 05:49 EST (History)
9 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.9-59.el6
Doc Type: Bug Fix
Doc Text:
Cause: A previous change caused multipath to store multiple duplicate blacklist entries Consequence: listing multipath's configuration showed multiple duplicate entries Fix: Multipath now checks for duplicates before storing configuration entries, and only stores unique ones. Result: Multipath no longer shows duplicate entries.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:49:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gris Ge 2012-04-09 03:18:16 EDT
Description of problem:
device-mapper-multipath-0.4.9-53.el6.x86_64 are providing duplicated entries in "blacklist" section:
===
        device {
                vendor "IBM"
                product "Universal Xport"
        }
        device {
                vendor "IBM"
                product "Universal Xport"
        }
        device {
                vendor "IBM"
                product "S/390.*"
        }
        device {
                vendor "IBM"
                product "S/390.*"
        }
        device {
                vendor "DELL"
                product "Universal Xport"
        }
        device {
                vendor "DELL"
                product "Universal Xport"
        }
===

No side effect found.

Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.9-53.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Check the "blacklist" multipathd -k'show config'

  
Actual results:
Found duplicated blacklist entries.

Expected results:
No duplicated blacklist entries.

Additional info:
It's a regression, but no side effect found, hence requesting fix for RHEL 6.4 as https://bugzilla.redhat.com/show_bug.cgi?id=752989#c35
Comment 2 Ben Marzinski 2012-04-11 22:52:38 EDT
This is simply a cosmetic issue. There's no reason to fix it for 6.3.
Comment 3 Gris Ge 2012-04-27 04:27:45 EDT
This bug might be caused by bug #803527.

The patch of it contain duplicate blacklist entries.
Comment 4 Ben Marzinski 2012-10-10 12:39:31 EDT
Fixed.  Multipath now checks if the new entry is a duplicate before storing.
Comment 6 Gris Ge 2013-01-15 02:43:07 EST
no duplicate blacklist entries in device-mapper-multipath-0.4.9-63.el6.x86_64.

VERIFY.
Comment 8 errata-xmlrpc 2013-02-21 05:49:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0458.html

Note You need to log in before you can comment on or make changes to this bug.