Bug 81084 - RFE: firstboot should offer to run makewhatis.cron and/or slocate.cron
RFE: firstboot should offer to run makewhatis.cron and/or slocate.cron
Status: CLOSED DUPLICATE of bug 87583
Product: Red Hat Linux
Classification: Retired
Component: firstboot (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2003-01-03 20:10 EST by Richard Lloyd
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:50:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Richard Lloyd 2003-01-03 20:10:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021202

Description of problem:
When phoebe (or indeed any previous Red Hat Linux release)
is first installed, the "man -k" and "slocate" commands
don't initially work, which doesn't give a good impression.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install phoebe and log in right away as a user
2. Try "man -k file"
3. Try "slocate motd"

Actual Results:  The "man -k" and "slocate motd" commands don't find anything and
are actually completely "broken" immediately after a Red Hat install.

Expected Results:  Both commands should display a list of matches (e.g. for "a2ps"
and "/etc/motd" respectively at the very least).

Additional info:

It isn't until the /etc/cron.daily/makewhatis.cron and
/etc/cron.daily/slocate.cron commands are run via cron
at 4.00am or so the next day that the "man -k" and "slocate"
commands actually work.

It gets even worse for the home user who powers off their
machine overnight - they have to wait for anacron to kick-in an hour
after their next reboot at least a day later (and their machine has
to stay up a full hour for anacron to indeed kick in).

It would make much more sense for "firstboot" to offer to run
the makewhatis.cron and slocate.cron scripts (or, if you want to
be fascistic, just fork them off and let them churn without giving
the user a choice :-( ). That way, if the user doesn't run them,
they've broken the system and have been told about it...
Comment 1 Chris Ricker 2003-01-11 10:44:59 EST
Agreed -- an dialog asking about running initial scripts would be nice

The more-or-less equivalent to firstboot in Debian does that, if I remember
Comment 2 Brent Fox 2003-04-01 15:56:56 EST

*** This bug has been marked as a duplicate of 87583 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:50:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.