Bug 810843 - LVMError: vgcreate failed for VolGroup: 12:59:08,603 ERROR : Incorrect metadata area header checksum on /dev/sda2 at offset 4096
LVMError: vgcreate failed for VolGroup: 12:59:08,603 ERROR : Incorrect me...
Status: CLOSED DUPLICATE of bug 816059
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.3
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Paolo Bonzini
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 07:29 EDT by daiwei
Modified: 2012-07-20 09:38 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-20 09:38:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daiwei 2012-04-09 07:29:29 EDT
Description of problem:

Install RHEL6.3 32 bit guest on virtio-scsi disk, failed. Get the following error:
LVMError: vgcreate failed for VolGroup: 12:59:08,603 ERROR   :   Incorrect metadata area header checksum on /dev/sda2 at offset 4096


Version-Release number of selected component (if applicable):
# uname -r ; rpm -q qemu-kvm
2.6.32-259.el6.x86_64
qemu-kvm-0.12.1.2-2.270.el6.x86_64


guest kernel:
2.6.32-259.el6.i386

How reproducible:
3/3

Steps to Reproduce:
1.install rhel6.3 32 bits guest with virtio scsi disk
e.g
# /usr/libexec/qemu-kvm ... -drive file=/home/rhel6.3-32.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,aio=native,media=disk,werror=stop,rerror=stop -device virtio-scsi-pci,id=bus1 -device scsi-hd,bus=bus1.0,drive=drive-virtio-disk0,id=virtio-scsi-pci0
2.
3.
  
Actual results:
install guest failed, when formatting disk gets error:

LVMError: vgcreate failed for VolGroup: 12:59:08,603 ERROR   :   Incorrect metadata area header checksum on /dev/sda2 at offset 4096


Expected results:
install guest successfully.

Additional info:
with virtio-blk-pci no this issue.
install RHEL6.3 64 bits guest no this issue.
Comment 3 Ademar Reis 2012-04-09 08:45:10 EDT
Please always include the full command line you're using to call qemu (if you're using libvirt, you can get it with "ps auxw")
Comment 4 daiwei 2012-04-09 10:52:44 EDT
Sorry, here is my full command line.

/usr/libexec/qemu-kvm -cpu cpu64-rhel6 -rtc base=localtime,clock=host,driftfix=slew -M rhel6.3.0 -enable-kvm -name rhel6.3-32 -smp 4,cores=2,threads=1,sockets=2 -m 4G -uuid c944829b-9aa0-46a2-b3d0-493c135da24d -boot menu=on -drive file=/home/rhel6.3-32.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none,aio=native,media=disk,werror=stop,rerror=stop -device virtio-scsi-pci,id=bus1 -device scsi-hd,bus=bus1.0,drive=drive-virtio-disk0,id=virtio-scsi-pci0 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup-switch -device virtio-net-pci,netdev=hostnet0,id=net0,mac=44:37:E6:5E:A3:F7 -spice port=9000,disable-ticketing -vga qxl -global qxl-vga.vram_size=67108864 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6 -monitor stdio -usb -device usb-tablet,id=input1 -drive file=/home/RHEL6.3-20120329.0-Server-i386-DVD1.iso,if=none,media=cdrom,readonly=on,format=raw,id=drive-ide1-0-0 -device ide-drive,drive=drive-ide1-0-0,id=ide1-0-0,bootindex=1
Comment 5 Ademar Reis 2012-04-17 16:23:18 EDT
Corner case on a tech-preview feature, deferring to RHEL6.4
Comment 7 RHEL Product and Program Management 2012-07-10 03:16:34 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 RHEL Product and Program Management 2012-07-10 22:05:30 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 9 Paolo Bonzini 2012-07-20 09:38:52 EDT

*** This bug has been marked as a duplicate of bug 816059 ***

Note You need to log in before you can comment on or make changes to this bug.