Bug 810878 - [abrt] kernel: WARNING: at lib/list_debug.c:56 __list_del_entry+0x82/0xd0()
[abrt] kernel: WARNING: at lib/list_debug.c:56 __list_del_entry+0x82/0xd0()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:169082cfa106cfa6a66a47ff914...
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2012-04-09 10:01 EDT by Peter
Modified: 2012-05-14 14:03 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 14:03:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter 2012-04-09 10:01:24 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        rd.luks.uuid=luks-44562137-729a-4085-b4bd-88c31f9b8c25 rd.md=0 rd.lvm.lv=vg_ranieri/lv_swap  KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb LANG=en_US.UTF-8 ro rd.lvm.lv=vg_ranieri/lv_root root=/dev/mapper/vg_ranieri-lv_root rd.dm=0
comment:        Laptop ThinkPad Edge E420: open lid (OS is hibernated), type in password to unlock hdd, login to XFCE, switch to workspace #3, go to Manu->System->System Monitor (start it). It happens randomly
event_log:      2012-04-09-10:00:47> Smolt profile successfully saved
kernel:         3.3.0-8.fc16.x86_64
reason:         WARNING: at lib/list_debug.c:56 __list_del_entry+0x82/0xd0()
time:           Mon 09 Apr 2012 09:55:31 AM EDT

backtrace:
:WARNING: at lib/list_debug.c:56 __list_del_entry+0x82/0xd0()
:Hardware name: 114157U
:list_del corruption. next->prev should be ffff880231554be8, but was ffff8802315549b8
:Modules linked in: ppdev parport_pc lp parport fuse lockd ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_hdmi snd_hda_codec_conexant vfat fat arc4 uvcvideo videobuf2_core videodev media snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device v4l2_compat_ioctl32 videobuf2_vmalloc videobuf2_memops snd_pcm joydev microcode snd_timer snd_page_alloc iwlwifi i2c_i801 mac80211 cfg80211 iTCO_wdt iTCO_vendor_support r8169 mii thinkpad_acpi rfkill snd soundcore uinput sunrpc xts gf128mul dm_crypt sdhci_pci sdhci mmc_core wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 520, comm: udevd Tainted: G        W    3.3.0-8.fc16.x86_64 #1
:Call Trace:
: [<ffffffff81057aff>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81057bf6>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff812d4732>] __list_del_entry+0x82/0xd0
: [<ffffffff8119aed7>] evict+0x77/0x1a0
: [<ffffffff8119b105>] iput+0x105/0x200
: [<ffffffff811f0065>] sysfs_dentry_iput+0x35/0x40
: [<ffffffff811965b7>] ? __dentry_lru_del+0x27/0x60
: [<ffffffff81196720>] dentry_iput+0x80/0xf0
: [<ffffffff81197cae>] shrink_dentry_list+0x21e/0x260
: [<ffffffff81197eef>] shrink_dcache_parent+0x1ff/0x270
: [<ffffffff811efc8b>] sysfs_dentry_revalidate+0x9b/0xd0
: [<ffffffff8118e0b6>] do_lookup+0x236/0x3a0
: [<ffffffff8118efe0>] link_path_walk+0x150/0x8a0
: [<ffffffff8116d01b>] ? kmem_cache_alloc_trace+0x11b/0x150
: [<ffffffff81273b0a>] ? selinux_file_alloc_security+0x4a/0x80
: [<ffffffff8118edbd>] ? path_init+0x2cd/0x3a0
: [<ffffffff81190fa9>] path_openat+0xb9/0x3c0
: [<ffffffff81180d92>] ? do_sync_write+0xd2/0x110
: [<ffffffff811913d2>] do_filp_open+0x42/0xa0
: [<ffffffff8116e5f5>] ? kmem_cache_alloc+0x125/0x150
: [<ffffffff8119d42f>] ? alloc_fd+0x4f/0x150
: [<ffffffff81180a18>] do_sys_open+0xf8/0x1d0
: [<ffffffff81180b11>] sys_open+0x21/0x30
: [<ffffffff815fbca9>] system_call_fastpath+0x16/0x1b

smolt_data:
:
:
:General
:=================================
:UUID: 16264ab5-c996-42c1-8804-0c00c5456adf
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4190.40
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 4
:CPU Speed: 2100
:System Memory: 7898
:System Swap: 9951
:Vendor: LENOVO
:System: 114157U ThinkPad E420
:Form factor: Notebook
:Kernel: 3.2.10-3.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7241:6058:8674) pci, None, PCI/ISA, HM65 Express Chipset Family LPC Controller
:(32902:278:6058:8674) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:6058:8674) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:6058:8674) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:6058:8674) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7198:6058:8674) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 8
:(32902:7200:6058:8674) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:7188:6058:8674) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:132:32902:4885) pci, iwlwifi, NETWORK, Centrino Wireless-N 1000 BGN
:(32902:7202:6058:8674) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(4332:33128:6058:8674) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(4480:59427:6058:8674) pci, sdhci-pci, BASE, N/A
:(32902:7171:6058:8674) pci, ahci, STORAGE, 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
:(32902:7213:6058:8674) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:6058:8674) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:260:6058:8674) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:6058:8674) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_ranieri-lv_root / ext4 4096 4096 13081819 4005454 3350094 3276800 3062711 3062711
:/dev/sda2 /boot ext4 1024 1024 508745 412349 386749 128016 127987 127987
:/dev/sda1 WITHHELD vfat 4096 4096 1119856 1119768 1119768 0 0 0
:/dev/mapper/vg_ranieri-lv_home /home ext4 4096 4096 12369620 6505948 5886224 3098704 3016634 3016634
:
Comment 1 Josh Boyer 2012-04-09 10:09:48 EDT
Please try the 3.3.1 update.  It has a fix for an i915 hibernate corruption issue.
Comment 2 Peter 2012-04-09 10:32:58 EDT
(In reply to comment #1)
> Please try the 3.3.1 update.  It has a fix for an i915 hibernate corruption
> issue.

Since this crash, I've booted to 3.2.10-3. Will update to 3.3.1 and let you know. Thanks!

Note You need to log in before you can comment on or make changes to this bug.