Bug 811008 - Preupgrade with anaconda 17.19 does not load kickstart
Preupgrade with anaconda 17.19 does not load kickstart
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-04-09 16:47 EDT by Adam Williamson
Modified: 2012-04-11 13:21 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-17.20-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 13:21:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
init.log after applying the 'workaround' suggested by wwoods (3.50 KB, text/plain)
2012-04-09 18:53 EDT, Adam Williamson
no flags Details
test run with anaconda 17.19 and edited anaconda-lib.sh (225.65 KB, text/plain)
2012-04-09 20:27 EDT, Brian Lane
no flags Details
additional debugging (550.23 KB, text/plain)
2012-04-09 21:15 EDT, Brian Lane
no flags Details

  None (edit)
Description Adam Williamson 2012-04-09 16:47:55 EDT
With anaconda 17.19, which is intended to address outstanding showstoppers http://bugzilla.redhat.com/show_bug.cgi?id=810005 and http://bugzilla.redhat.com/show_bug.cgi?id=810391 in preupgrade, a new issue arises: again boot to anaconda fails during dracut stage because initqueue fails. This bug has been discussed in http://bugzilla.redhat.com/show_bug.cgi?id=810391 comments #5 to #11. The issue appears to be that the kickstart file loading fails. Marking as a Beta blocker, we have solid history for accepting showstopping preupgrade issues as beta blockers.
Comment 1 Will Woods 2012-04-09 17:53:24 EDT
Having both "stage2=hd:UUID=XXX" and "ks=hd:UUID=XXX" meant we had two jobs to perform when the disk with UUID=XXX appeared. Unfortunately, initqueue did unexpected things with the job names such that the two jobs collided.

Try this and tell me if it fixes the problem:

- boot with 'rd.break=cmdline'
- when the shell appears, do:
  sed -i 's/--unique//' /lib/anaconda-lib.sh
  exit

The patch I'm proposing does, basically, that. If you can confirm that works, we can skip the process of filing a new blocker bug when the next unexpected bug appears. :D
Comment 2 Adam Williamson 2012-04-09 18:53:39 EDT
Created attachment 576325 [details]
init.log after applying the 'workaround' suggested by wwoods

I tried wwoods' suggested workaround without success:

09-04-2012 14:34:01 < wwoods!wwoods@nat/redhat/x-sxoulxstnhtqfwjd: adamw: if you
 want to test the fix, it's pretty easy: boot with rd.break=cmdline, then:
09-04-2012 14:34:21 < wwoods!wwoods@nat/redhat/x-sxoulxstnhtqfwjd: sed -i 's/--u
nique//' /lib/anaconda-lib.sh
09-04-2012 14:34:37 < wwoods!wwoods@nat/redhat/x-sxoulxstnhtqfwjd: then exit the
 shell and it should start the installer

still get an initqueue failure, with a devexists-\\x2fdev\x2froot.sh that fails and also a kickstart.sh that still fails. There is no /tmp/ks.cfg or /tmp/ks.cfg.done. Here is the init.log.
Comment 3 Brian Lane 2012-04-09 20:27:03 EDT
Created attachment 576339 [details]
test run with anaconda 17.19 and edited anaconda-lib.sh

I added rd.break=cmdline rd.debug console=ttyS0 to the cmdline (rd.debug doesn't seem to log properly when used with rd.break=cmdline).

I edited anaconda-lib.sh to remove the --unique flag and to add the readlink modification to dev_is_mounted.
Comment 4 Brian Lane 2012-04-09 21:15:00 EDT
Created attachment 576354 [details]
additional debugging

added rd.udev.info and rd.udev.debug

Things seem to go wrong around line 11248 where the initqueue being run from udev.
Comment 5 Adam Williamson 2012-04-09 23:07:31 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Adam Williamson 2012-04-09 23:08:05 EDT
It turns out that also doing:

sed -i 's/1-.dev/1/' /lib/anaconda-lib.sh

to replicate the other part of wwoods' patch results in success. He didn't think it'd be important, but it is.
Comment 7 Fedora Update System 2012-04-10 00:13:54 EDT
anaconda-17.20-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/anaconda-17.20-1.fc17
Comment 8 Fedora Update System 2012-04-10 16:14:10 EDT
Package anaconda-17.20-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-17.20-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5559/anaconda-17.20-1.fc17
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-04-11 13:21:52 EDT
anaconda-17.20-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.