Bug 811010 - API for listing all repos by ID
API for listing all repos by ID
Status: CLOSED WORKSFORME
Product: Pulp
Classification: Community
Component: user-experience (Show other bugs)
Master
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jay Dobies
Preethi Thomas
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 16:52 EDT by Dennis Gregorovic
Modified: 2013-09-27 18:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 18:05:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gregorovic 2012-04-09 16:52:12 EDT
The "pulp-admin repo list" command is a bit slow, presumably because it's fetching a good amount of info from the db for each repo.  

$ time pulp-admin repo list | grep Id | wc -l
509

real    5m13.160s
user    0m9.232s
sys 0m0.643s

Can we have a new API that quickly returns just the list of repo IDs?
Comment 1 Michael Hrivnak 2013-09-27 18:05:48 EDT
This seems to have been fixed. The command can now returns lots of repo data very quickly.

$ time pulp-admin rpm repo list | grep Id | wc -l
506

real	0m1.840s
user	0m1.564s
sys	0m0.153s

Note You need to log in before you can comment on or make changes to this bug.