Bug 811011 - Fix apache configuration to speed up webUI
Fix apache configuration to speed up webUI
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 16:52 EDT by Justin Sherrill
Modified: 2013-08-16 14:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-22 14:32:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2012-04-09 16:52:29 EDT
Description of problem:

Currently the apache server is not configured optimally for web page access.  With a few modifications we can increase the speed by up to 50%.

changes to  /etc/httpd/conf.d/katello.conf



ExpiresActive On
<Directory "/usr/share/katello/public/assets">
  ExpiresDefault "access plus 1 year"
</Directory>
<Directory "/usr/share/katello/public//public/images">
  ExpiresDefault "access plus 1 year"
</Directory>


KeepAlive On
Comment 1 Justin Sherrill 2012-04-10 13:40:14 EDT
katello master commit:

3e78c402ba5fc2b2d095d5c76a683834873dcc27
Comment 3 Justin Sherrill 2012-04-11 16:33:06 EDT
system engine commit:
9ecac200e234584aa4342b1ddc570546c5258956
Comment 4 Corey Welton 2012-04-17 12:48:38 EDT
Testing notes: The following change is what landed in the build:

  ExpiresActive On
  <Directory "/usr/share/katello/public/">
    ExpiresDefault "access plus 1 year"
  </Directory>

Dev indicated it was opted to just apply the directive to the parent directory versus the two individual child directories above.

Verified in brew build - Version: 0.1.310-1.el6_2
Comment 6 Mike McCune 2013-08-16 14:20:41 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.