Bug 811032 - Improve "support" wording
Improve "support" wording
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 6.0.1
Assigned To: gsheldon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 19:04 EDT by dereed
Modified: 2012-09-19 23:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 22:15:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dereed 2012-04-09 19:04:36 EDT
Document URL:

http://docs.redhat.com/docs/en-US/JBoss_Data_Grid/6/html-single/Technical_Preview/index.html

Section Number and Name:

1.1. About JBoss Data Grid Usage Modes

Describe the issue:

"Library mode is included in the JBoss Data Grid 6 Beta but is not supported with a production level SLA due to inclusion as a technical preview."

This suggests that remote client-server mode *is* supported with a production level SLA in beta (which it is not).

Suggestions for improvement:

Change the wording to make it clear that library mode will be TP in GA.

In Beta, there's not really any difference in support between beta and beta TP.  Neither have production-level support.
Comment 1 Misha H. Ali 2012-04-10 23:39:08 EDT
Alan, need your comment on the below:

> This suggests that remote client-server mode *is* supported with a production
level SLA in beta (which it is not).

and

> Change the wording to make it clear that library mode will be TP in GA.

As I understand it, library mode is not a technical preview for GA. Can you clarify, please?
Comment 2 Alan Santos 2012-04-11 08:48:47 EDT
Library mode is technical preview for GA.  Beta is not supported with a production level SLA. 

My suggestion is to state:

"Library mode is included in the JBoss Data Grid 6 Beta and will be supported at GA as a technical preview."
Comment 3 gsheldon 2012-04-11 19:21:02 EDT
These changes will appear on the documentation stage once brewed:


"Remote Client-Server mode is included and supported in JBoss Data Grid 6 Beta but is not supported with a production level SLA at this time."

"Library mode is included in the JBoss Data Grid 6 Beta but is not supported with a production level SLA. Library mode will be supported in GA as a technical preview."

This bug will be updated with a link when available.

Note You need to log in before you can comment on or make changes to this bug.