This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 811083 - gdisk needs to be included on install/rescue image
gdisk needs to be included on install/rescue image
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-09 23:49 EDT by joshua
Modified: 2012-09-06 00:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: lorax-17.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-06 00:41:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description joshua 2012-04-09 23:49:49 EDT
Description of problem:

gdisk is essential these days.  parted is not nearly as precise, we need gdisk included for GPT situations just like fdisk is included.

Please include gdisk in the installer/rescue image for Fedora 17 !!


Version-Release number of selected component (if applicable):

Fedora 17 Alpha
Comment 1 Bill Nottingham 2012-04-10 16:22:44 EDT
I would think if it's that much better we'd use it for everything; would rather not support a "use X or Y" scenario.
Comment 2 Chris Lumens 2012-04-10 16:29:51 EDT
Yeah, parted is the tool we use for everything - including doing partitioning in the installer.  If there are problems with parted, that should be fixed instead.
Comment 3 joshua 2012-04-10 16:44:49 EDT
Ok, but why then do we include fdisk?  Answer:  because it is infinitely more precise in CLI mode.  All I'm asking for is gdisk, the GPT-aware version of fdisk, to be included *just like fdisk itself is*.  In fact, gdisk could take the place of fdisk, as it does it's job for MBR-style disks as well.

parted is not as clean, precise, or straight-forward as fdisk/gdisk.  It didn't used to matter when most setups used MBR... if we were in the installer or rescue mode and needed it, we had fdisk.  But fdisk no longer works for lots of systems out there.  I guess I'm really just asking for the next evolution of fdisk, gdisk, to take it's place.

Thank you for your consideration, I realize keeping everyone happy is nearly impossible.
Comment 4 joshua 2012-04-11 21:00:34 EDT
gdisk enables you to enter any arbitrary GPT partition type.  parted doesn't.
If you need to partition and leave space for the microsoft reserved partition, how do you do this with parted?  You don't.

How about gdisk's ability to convert an MBR disk to GPT format without data loss. gdisk permits doing this... does parted allow this?

What about converting a disk that uses BSD disklabels to GPT format, or you want to convert a BSD disklabel within an MBR or GPT partition, into GPT partitions, without data loss?

Or if you need to create or modify a hybrid MBR ( often used on Intel-based Macs to enable them to dual-boot with Windows.).  How do you do this with parted?

You want to back up and restore your partition table to or from an ordinary disk file.  Parted?

This is why I'm asking for gdisk to be included... parted alone just doesn't cut it.
Comment 5 Fedora Update System 2012-04-20 04:05:22 EDT
lorax-17.15-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lorax-17.15-1.fc17
Comment 6 Fedora Update System 2012-04-21 17:06:07 EDT
Package lorax-17.15-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-17.15-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6336/lorax-17.15-1.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-04-23 15:00:58 EDT
lorax-17.16-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lorax-17.16-1.fc17

Note You need to log in before you can comment on or make changes to this bug.