Bug 811087 - atheros ar3012 bluetooth in asus ux31e/ux21e not recognized (reopening)
atheros ar3012 bluetooth in asus ux31e/ux21e not recognized (reopening)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 00:22 EDT by John Heidemann
Modified: 2012-04-26 00:29 EDT (History)
5 users (show)

See Also:
Fixed In Version: kernel-2.6.43.2-6.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-18 15:29:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel patch from http://article.gmane.org/gmane.linux.bluez.kernel/18830 (1.70 KB, patch)
2012-04-10 00:24 EDT, John Heidemann
no flags Details | Diff
kernel spec patch, now with more sensible filename and patchno (644 bytes, patch)
2012-04-10 00:25 EDT, John Heidemann
no flags Details | Diff

  None (edit)
Description John Heidemann 2012-04-10 00:22:54 EDT
Description of problem:
(this bug duplicates #808650 to reopen it since 3.3.1 doesn't have the patch)

Bluetooth on an ASUS UX31E (tested) refuses to discover devices during pairing.



Version-Release number of selected component (if applicable):
kernel-3.3.1-3.fc16.x86_64

How reproducible:
every time


Steps to Reproduce:
1. boot fedora 16 with patches to linux-3.3.1-3.fc16.x86_64 into gnome-3
2. choose "set up a new device..." from the bluetooth menu > continue to device
search
3. push the "pairing" button on your keyboard
4. be disappointed when your keyboard (in my case, a microsoft bluetooth
keyboard 6000) doesn't show up


Actual results:
no pairing.  no keyboard. no love.
still, even since 3.3.1 and #80650

Expected results:
keyboard discovery and typing glory.


Additional info:
Patch at http://thread.gmane.org/gmane.linux.bluez.kernel/18801
applied in Ubunutu https://help.ubuntu.com/community/AsusZenbook
as of 2012-03-22.

The web says the patch is in linux-next.
I thought it was in 3.3.1 (according to the changelog).
But 3.3.1-3.fc16 still leaves me heartbroken.
I don't know how much pain it is to get a patch into the fedora kernel, but
it'd be nice to see this in until the Mainline Kernel catches up.

(I've updated my patch to have a proper name, none of this linux-2.6 junk.)
Comment 1 John Heidemann 2012-04-10 00:24:01 EDT
Created attachment 576376 [details]
kernel patch from http://article.gmane.org/gmane.linux.bluez.kernel/18830
Comment 2 John Heidemann 2012-04-10 00:25:16 EDT
Created attachment 576377 [details]
kernel spec patch, now with more sensible filename and patchno
Comment 3 Josh Boyer 2012-04-10 15:06:08 EDT
OK, the patch went into 3.4-rc1.  I'll get this into Fedora shortly.
Comment 4 Josh Boyer 2012-04-10 15:15:21 EDT
Applied to F15-F17.  Will be in the next submitted update.  Bodhi will leave a comment here when that has been pushed to the repos.
Comment 5 Fedora Update System 2012-04-13 20:39:59 EDT
kernel-2.6.43.2-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.43.2-2.fc15
Comment 6 Fedora Update System 2012-04-14 19:18:33 EDT
Package kernel-2.6.43.2-2.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-2.6.43.2-2.fc15'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5905/kernel-2.6.43.2-2.fc15
then log in and leave karma (feedback).
Comment 7 John Heidemann 2012-04-16 12:56:25 EDT
Wrt comment #4, the ath3k patch doesn't seem to be in kernel-3.3.1-5.
(But not clear to me what "next submitted update" is exactly.)
Comment #6 speaks only of fc15, and I'm running f16, so perhaps it's
still working its way through?
Comment 8 Josh Boyer 2012-04-16 14:58:34 EDT
(In reply to comment #7)
> Wrt comment #4, the ath3k patch doesn't seem to be in kernel-3.3.1-5.
> (But not clear to me what "next submitted update" is exactly.)
> Comment #6 speaks only of fc15, and I'm running f16, so perhaps it's
> still working its way through?

I'm submitting an update today that should cover this in F16.
Comment 9 Fedora Update System 2012-04-16 15:07:00 EDT
kernel-3.3.2-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.3.2-1.fc16
Comment 10 Fedora Update System 2012-04-16 15:10:22 EDT
kernel-3.3.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.3.2-1.fc17
Comment 11 Fedora Update System 2012-04-18 15:29:57 EDT
kernel-3.3.2-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-04-21 12:46:46 EDT
kernel-2.6.43.2-6.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.43.2-6.fc15
Comment 13 Fedora Update System 2012-04-22 00:15:01 EDT
kernel-3.3.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2012-04-25 23:28:01 EDT
kernel-2.6.43.2-6.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 John Heidemann 2012-04-26 00:29:17 EDT
I can confirm that kernel-3.3.2-6.fc16 Works For Me.
(I think 3.3.2-1 also did, but that's already history)
Thanks!

Note You need to log in before you can comment on or make changes to this bug.