Bug 81109 - installer crashed w/file cannot be opened error
installer crashed w/file cannot be opened error
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: libmng (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-04 16:49 EST by Frank Saxton
Modified: 2013-04-02 00:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-05 00:43:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Saxton 2003-01-04 16:49:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
During RH 8.0 install, received 
/mnt/sysimage/var/tmp/libmng-1.0.4-1.i386.rpm cannot be opened mesg
installer crashes.
Tested iso on CDROM ok.  CDROM was created from ftp download

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot from diskette
2.build server with most options and all 3 GUIs
3.fails about 1/2 way thru the install process
    

Actual Results:  Install went fine until above reported crash

Expected Results:  duh..

Additional info:

This is a pretty new PC that has been running Win2KPro for some time.  hdb was 
blank and was used to install linux
Comment 1 Frank Saxton 2003-01-04 17:19:39 EST
Tried to install by making less option selections.  Failed much earlier, in the 
same way..this time on libz.  Can't attach the crash file since it was 
formatted for UNIX and not for DOS.
Comment 2 Frank Saxton 2003-01-04 17:25:43 EST
Files on CDROM that's being complained about
09/03/2002  01:27p             117,947 libmng-1.0.4-1.i386.rpm
09/03/2002  01:00p              36,660 zlib-1.1.4-4.i386.rpm
Comment 3 Frank Saxton 2003-01-04 18:35:36 EST
Tried installing just the RH workstation software.  Failed in the same way 
(zlib).  The debugger said fopen /mnt/source/.discinfo not found.  I presume 
this is a file being written to on the hard drive being built.  Fails about 1/4 
way through the install process.  I'm guessing this must be an anaconda bug.. 
File already open/locked?
Comment 4 Frank Saxton 2003-01-04 20:06:16 EST
At the time of failure, the subdirectory /mnt/source does not exist on hdb.  I 
presume that it once did otherwise the install wouldn't have gotten this far, 
right?  Don't see anything in the errata or bug lists about this although I 
assume that it fails this way for everyone.
Comment 5 Frank Saxton 2003-01-05 00:43:34 EST
Found some information in a closed bug report that fixed my problem.  
Apparently a lot of people are having problems with CDROMs and the update 
software I downloaded served as a good workaround.  As a suggestion, you might 
consider implementing a less fatal error handler.  You also might consider 
putting this info in the errata sheets since I had to do a *LOT* of searching 
to actually find teh info I needed.
Comment 6 Michael Lee Yohe 2003-01-07 11:48:03 EST
Resolution == RESOLVED DUPLICATE 75377
Component == Anaconda

If you had included the Anaconda dump file when you initially filed this bug,
you would have been pointed to the bug that would have assisted you.  Glad you
found the solution to your problem, though.

Note You need to log in before you can comment on or make changes to this bug.