Bug 811095 - kmix doesn't have "Select Master Channel" menu
kmix doesn't have "Select Master Channel" menu
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdemultimedia (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-10 01:57 EDT by Joseph Shraibman
Modified: 2012-04-11 09:38 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-10 08:24:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Shraibman 2012-04-10 01:57:33 EDT
Description of problem:
I'm having a problem in my setup where I can't use my microphone.  The only available input channel is audio capture.  Kmix only has audio capture under input channels and a master output volume control, the same controls as alsamixer w/o arguments (the "default" sound card, whatever that is).  I want to be able to have all the settings that are shown in "alsamixer -c0" and have access to my microphone.

According to the online help in kmix under the Settings submenu there should be a "Configure Channels" menu but I'm not seeing it.  Either the KDE handbook is wrong or there is something wrong with kmix.

Version-Release number of selected component (if applicable):
kdemultimedia-4.6.5-2.fc15.x86_64


How reproducible:
always


Additional info:
If I remove /etc/asound.conf I have access to my microphone but then only one program can output sound at a time so I had to put it back.
Comment 3 Joseph Shraibman 2012-04-10 12:50:39 EDT
So "Select Master Channel" is omitted on purpose if pulseaudio is found?  Shouldn't it be greyed out instead to avoid confusion?
Comment 4 Rex Dieter 2012-04-10 16:57:06 EDT
One could argue your suggestion to be more confusing.

Why is it greyed out?  why can't I select it?
Comment 5 Kevin Kofler 2012-04-11 09:38:37 EDT
*** Bug 811475 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.