Bug 81111 - domino R5 hangs java 1.1.8 glibc-2.2.5-42
domino R5 hangs java 1.1.8 glibc-2.2.5-42
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-04 17:27 EST by Mike Rambo
Modified: 2016-11-24 09:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-24 17:34:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Rambo 2003-01-04 17:27:41 EST
Description of problem:
Domino R5 server (Lotus Notes) hangs when setup is attempted after installation. Appears to be a problem between glibc-2.2.5-42 and the IBM Java version 1.1.8 used by Domino.


Version-Release number of selected component (if applicable):
glibc-2.2.5-42

How reproducible:
Install Domino R5 server package and run 'http httpsetup' to start the setup process. Will see a banner, a libjitc.so error, and then hangs. The libjitc error I believe is not relavent to the problem. Installing the full IBM Java 1.1.8 jre package gets rid of the libjitc error but not the hang.

Steps to Reproduce:
1.Install Domino R5 version 5.07
2.run 'http httpsetup' to configure
3.
    
Actual results:
Prints a banner and hangs.

Expected results:
Should print several messages after the banner, the first being java related, and enable you to configure the server via a web browser.

Additional info:
This appears to be a conflict between the java version used by Domino R5 v5.07 (which is IBM Java v1.1.8-?) and glibc version 2.2.5-42. Steping glibc back to version 2.2.5-34 eliminates the problem.
Comment 1 Ulrich Drepper 2003-04-22 03:56:55 EDT
There is not much we can do.  All Java implementations had big ABI problems in
the past.  IBM's is especially notorious, they are violating ABI rules left and
right.  Every tiny change in the runtime can upset it.

If possible, stay away from IBM's JDR, Sun's seems to be much cleaner.  And it
works on RHL9.  Of course I expect Domino will only work with IB's
implementation.  So the only option is to stay with the code IBM certified or
pester them for new code which works on the release you're trying to use.  There
are IBM JREs which work on RHL8 and maybe RHL9 if LD_ASSUME_KERNEL=2.4.1 is used.
Comment 2 Brian Brock 2003-06-24 17:34:21 EDT
closing, there's no bug in the Red Hat glibc.

Note You need to log in before you can comment on or make changes to this bug.